Unable to Chromecast from Firefox Beta (35)

RESOLVED FIXED in Firefox 35

Status

()

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: shovav, Assigned: mfinkle)

Tracking

35 Branch
Firefox 37
Other
Android
Points:
---

Firefox Tracking Flags

(firefox34 unaffected, firefox35 fixed, firefox36 fixed, firefox37 fixed, fennec35+)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Android; Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Build ID: 20141203233411

Steps to reproduce:

When I go to Menu->Tools there is no tab mirroring option. I tried mirroring a video but there's no chromecast icon. I am using Firefox Beta version 35 for Android and also tried Firefox 34 (non beta). I am on a phone with Lollipop. 

I tried Firefox on a tablet with kitkat and have the same issue. In Firefox 35, if I go to about :devices I see my chromecast along with its ip address. In the Android chromecast app I see my chromecast device and can chromecast from other compatible chromecast apps


Actual results:

Nothing 


Expected results:

My tab should have been mirrored to my chromecast
Can you provide the video that you tried to mirror? Do you see the option on other websites?
Flags: needinfo?(segilara+firefoxbugzilla)
This is the site I used to test mirroring:http://people.mozilla.org/~mfinkle/casting/test.html I also tried YouTube in desktop mode. The video played just fine in Firefox but there wasn't a chromecast icon
Flags: needinfo?(segilara+firefoxbugzilla)
What about other sites with just text for example?
Component: General → Screencasting
Same thing the mirroring option isn't there
Can confirm it with 35beta. 34 stable on the other hand has the mirror option available
Can confirm. I am using my Chromecast today and there is no availability in media nor in the ability to mirror a tab in product.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Summary: Can't Chromecast → Regression: Unable to Chromecast from Firefox Beta (35)
Looks like trunk Nightly is fine, Aurora (36)/Beta seem to be affected. Only on trunk do I see mirror tab and have the ability to cast a media (e.g, MP4). On Aurora/Beta, all those options are missing.
Actually hold that. All of a sudden now I am seeing the ability to cast (35) and mirror (36) now in the Beta/Aurora. I'm not sure what I did, but I assume initially it did not find the device on my network.
This works for me. I rebooted my Chromecast, I ensured the browser sees my devices (about:devices), I connected Chromecast in the Chromecast application and I can't reproduce. I did initially see the inability to cast but I can only guess that the browser didn't see the device. WFM/
Status: NEW → UNCONFIRMED
tracking-fennec: ? → ---
Ever confirmed: false
Summary: Regression: Unable to Chromecast from Firefox Beta (35) → Unable to Chromecast from Firefox Beta (35)
I had the same problem with Mirror Tab not being visible in Firefox 35.  Based on the previous comment I tried about:devices and surprisingly found my Chromecast listed.  I tried looking in about:config and found browsing.mirror.enabled was set to false.  I set that to true, did a Force Stop, and mirabile dictu Mirror Tab appeared.  Seems to be working reasonably well for me on a 2013 Moto X.  It appears to respect portrait and landscape but only when set prior to mirroring.
Even though I can Chromecast, I think Mirror Tab/Stop Mirroring should be shown in menu, I don't see it at all in Firefox 35.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Are we supposed to be showing 'Mirror Tab' in the menu on 35?
Flags: needinfo?(mark.finkle)
(In reply to Aaron Train [:aaronmt] from comment #12)
> Are we supposed to be showing 'Mirror Tab' in the menu on 35?

We have two preferences for controlling mirroring on Android:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/app/mobile.js#286

browser.mirroring.enabled
browser.mirroring.enabled.roku

The first should control all aspects of mirroring. The second should control whether the Roku supports mirroring. Both are | false | on Release builds.

Since Chromecast support mirroring, I assume we should make "browser.mirroring.enabled" = true everywhere.

What do you think Brad? Also, should Desktop use similar preferences?
Flags: needinfo?(mark.finkle) → needinfo?(blassey.bugs)
(In reply to Mark Finkle (:mfinkle) from comment #13)
> (In reply to Aaron Train [:aaronmt] from comment #12)
> What do you think Brad? Also, should Desktop use similar preferences?

Yea, it probably should
Flags: needinfo?(blassey.bugs)
Let's enable mirroring in all channels
Assignee: nobody → mark.finkle
Attachment #8537403 - Flags: review?(blassey.bugs)
Attachment #8537403 - Flags: review?(blassey.bugs) → review+
Comment on attachment 8537403 [details] [diff] [review]
enable-mirroring v0.1

Approval Request Comment
[Feature/regressing bug #]: Just removing a RELEASE_BUILD condition.
[User impact if declined]: No tab mirroring support for devices that support it, like Chromecast
[Describe test coverage new/current, TBPL]: This has been enabled and working for weeks on Nightly and Aurora
[Risks and why]: Low
[String/UUID change made/needed]: none
Attachment #8537403 - Flags: approval-mozilla-beta?
Attachment #8537403 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2ba3ce59e0e3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Attachment #8537403 - Flags: approval-mozilla-beta?
Attachment #8537403 - Flags: approval-mozilla-beta+
Attachment #8537403 - Flags: approval-mozilla-aurora?
Attachment #8537403 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.