Closed Bug 1110637 Opened 7 years ago Closed 7 years ago

[Calendar] Can not login CalDav account successfully.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED INVALID
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(7 files)

Using the google CalDAV URL(https://apidata.googleusercontent.com/caldav/v2/) is also incorrect。I think this is because that we did not get the Google's oAuth 2.0 authentication flow to get API key.
 
 DEFECT DESCRIPTION:
 A prompt message "Something is wrong. Try again later." will pop up, it can not login successfully.
 pls check the screenshot in attached.
 
 Zhou qin :0752-2639384(61384)
 
  REPRODUCING PROCEDURES:
 1. Enter Calendar -> Options -> Settings -> Add Account -> CalDav,
 2. Input the Username: ls.hzval.com, Password:test.1234, URL:https://www.google.com/calendar/dav/, touch "Save", check the behavior of Test Device. -- KO
 
 
  EXPECTED BEHAVIOUR:
 It can login the google CalDav account.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
Attached image screenshot
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Flags: needinfo?(fan.luo)
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Attached video video of Flame 2.1
Hi Josh,
This issue can be repro on Woodduck 2.0M and Flame 2.0/2.1/2.2
On Woodduck 2.0, after tap save, it will display "Wrong login and/or password."
On Flame 2.0/2.1/2.2, after tap save, it will display "Something is wrong. Try again later."
Found time: 17:16
See attachment: Flame_video.MP4 and logcat_1716.txt

Woodduck versions:
Gaia-Rev        eb015be03823460c5dae8812d7aded9087e0b8a5
Gecko-Rev       e3dc9e5cba07c956e34f03fc0b8fcd2342d57234
Build-ID        20141215050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1418591084
FW-Date         Mon Dec 15 05:05:11 CST 2014

Flame 2.0 versions:
Gaia-Rev        f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/28bacbc71efb
Build-ID        20141214000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141214.034226
FW-Date         Sun Dec 14 03:42:37 EST 2014
Bootloader      L1TC00011880

Flame 2.1 versions:
Gaia-Rev        97873dca486abf4162a3345e71b375806937bdec
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ec87f4f41d3d
Build-ID        20141214001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141214.034723
FW-Date         Sun Dec 14 03:47:33 EST 2014
Bootloader      L1TC00011880

Flame 2.2 versions:
Gaia-Rev        e2a3e606675c346b6e6f35351a458040be599b09
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/f14dcd1c8c0b
Build-ID        20141214040212
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141214.073552
FW-Date         Sun Dec 14 07:36:04 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo) → needinfo?(jocheng)
Hi Lance,
Please attach Woodduck logcat as this is reported on Woodduck. thanks!
Flags: needinfo?(jocheng) → needinfo?(liuke)
Hi Gary,
Could you please help to check the problem? Thanks!
Flags: needinfo?(gchen)
Hi Luke,
Could you please help to check the problem? Thanks!
Flags: needinfo?(lchang)
Blocks: Woodduck_P2
(In reply to Josh Cheng [:josh] from comment #5)
> Hi Lance,
> Please attach Woodduck logcat as this is reported on Woodduck. thanks!

Hi Josh,
    We have uploaded Woodduck logcat and screenshot to Bugzilla, please see logcat_1006.txt and 2014-12-16-10-06-17.png.
Flags: needinfo?(liuke)
Please ignore attachment logcat_1006.txt and 2014-12-16-10-06-17.png, see new attachment logcat_1023.txt and 2014-12-16-10-23-44.png, thanks.
(In reply to sync-1 from comment #0)
> URL(https://apidata.googleusercontent.com/caldav/v2/) is also incorrect。I
> think this is because that we did not get the Google's oAuth 2.0
> authentication flow to get API key.

Yes, that's why we provide the "Google" option instead. Please use it for testing Google Calendar or choose another CalDav provider to test the "CalDav" option.

Please refer to [1], the old endpoint "https://www.google.com/calendar/dav" is deprecated and no longer supported.


[1] https://developers.google.com/google-apps/calendar/caldav/v2/guide#connecting_to_googles_caldav_server
Flags: needinfo?(sync-1)
Flags: needinfo?(lchang)
Flags: needinfo?(gchen)
User error, close.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
blocking-b2g: 2.0M? → ---
clear NI since this bug has been closed.
Flags: needinfo?(sync-1)
You need to log in before you can comment on or make changes to this bug.