Closed Bug 1110645 Opened 5 years ago Closed 4 years ago

[Flame][Homescreen]After ending a MT call while you are adding the smart collections, smart collections can't be added to Homescreen successfully.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: yue.xia, Unassigned)

References

Details

Attachments

(3 files)

[1.Description]:
[Flame][v2.1&v2.2][Homescreen] While adding the smart collections, answer a MT call and then hang it up , or directly  reject this MT call,   then smart collections can't be added to Homescreen successfully.
Found time: 15:35
See attachment: logcat_1535.txt & video.MP4

[2.Testing Steps]: 
Pre: Insert  a SIM card to device.
1. Long tap the empty space on Homescreen.
2. Tap "Add Smart Collections" .
3. Select some options and tap "OK".
4. While adding the smart collections,   a MT call comes in.
5. Answer the MT call and then hang it up , or directly  reject this MT call



[3.Expected Result]: 
5. After hang up the call, it goes back to Homescreen, the smart collections could be added to Homescreen successfully.

[4.Actual Result]: 
5. After hang up the call, it goes back to Homescreen, but the smart collections can't be added to Homescreen.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        97873dca486abf4162a3345e71b375806937bdec
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9faa165ac85d
Build-ID        20141211001204
Version         34.0

Flame 2.2 build:
Gaia-Rev        1a956437210d2b16988d2ddbf40c9a38d8474435
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/d92db71d4e67
Build-ID        20141211040208
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID:  Free Test
Attached video video
Attached file logcat
Attached file Flame2.2 logcat
Dear Eric,
On latest Flame2.1, some of the selected smart collections can be added to Home screen after answering a MT call.  But on Flame 2.2, none of the selected smart collections can be added to Home screen after answering a MT call. Could you help with it, thanks!
See attachments: Flame2.2_logcat_1616.txt
Reproducing time: 16:16
Reproducing rate: 5/5

Flame 2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0

Flame 2.2 build:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Flags: needinfo?(echang)
Hi Johan, Could you help to take a look at this, thanks.
Flags: needinfo?(echang) → needinfo?(jlorenzo)
I don't remember testing this scenario on 2.0. This bug may have been here since the Vertical Homescreen.

QA wanted to check 2.0.
Flags: needinfo?(jlorenzo)
Keywords: qawanted
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #5)
> QA wanted to check 2.0.

Issue is reproducible on Flame 2.0 and on base image v188-1 (v2.0). If a call comes in while DUT is on the 'Loading' screen of adding several smart collections, the adding will be interrupted and resulting in none or partial of the smart collections being added after the call. Repro rate is 5/5.

Device: Flame 2.0 (shallow flash)
BuildID: 20150106184227
Gaia: f76014fd2c7528493b90d759c68ec3070233d094
Gecko: 53ff92e647a0
Version: 32.0 (2.0)
Firmware: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(jlorenzo)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Flags: in-moztrap?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.