offline:news:can't read a downloaded news mesgs while offline

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I've seen this in this weeks trunk builds (using 2001111203 build now)
on all platforms.

If you select a newsgroup to download (either by download/sync, properties
window,etc.), then go offline and try to click on a news mesg
the result is you can't read it. The Message pane in messenger
is blank. It doesn't say "The body of this message has not been downloaded from 
the server for reading offline. To read this message,.. ". It's just
white. If I open the downloaded news mesg in a seperate window, the body
is blank.

Also when you go back online and try to click on a mesg nothing happens
either. I have to select another newsgroup and then go back to downloaded
newsgroup in order to read any of those mesgs online. It's kind of
a refresh problem?

Steps to reproduce:
1.Download a newsgroup
2.go offline
3.Click on a news mesg:
 result: blank
 expected: to see the body of the news mesg
(Reporter)

Comment 1

16 years ago
Don't know if the problems with news is related to
this downloading news bug 109232.
(Assignee)

Comment 2

16 years ago
probably the url parsing changes - I'll look into it. None of the offline code
has changed in months.
(Assignee)

Comment 3

16 years ago
I'm not sure who broke this - my guess would be some necko guy. Offline imap
still works, and it uses the same mechanism as offline news, pretty much. The
thing that's broken is reading messages from the local cache - it doesn't matter
if you're online or offline.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

16 years ago
OK, the problem is that there's no request in the protocol object, so the
GetStatus call returns an error, and the uri loader bails. I'm not sure if this
is new behaviour on the uriloader's part, or if the fact that the request is
null is new behaviour. IMAP handles this by just returning NS_OK if there's no
request, but nsMsgProtocol::GetStatus returns NS_ERROR_FAILURE. A simple fix
would be to change nsMsgProtocol::GetStatus.
(Assignee)

Comment 5

16 years ago
OK, it was rpotts' change on 11/12 to the uriloader that caused this problem. I
guess I'll have to work around it.
(Assignee)

Comment 6

16 years ago
Created attachment 60496 [details] [diff] [review]
proposed fix

uri loader code bails out if getstatus returns error. For offline news (and
imap), there's no request, so we were erroring out for news (but not imap,
which returns NS_OK in this case). Just making the base protocol do the same.

Comment 7

16 years ago
Comment on attachment 60496 [details] [diff] [review]
proposed fix

sr=mscott
Attachment #60496 - Flags: superreview+
(Assignee)

Comment 8

16 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

16 years ago
using 
2001121003 windows nt 4.0
2001121008 linux 2.2, mac os 9.1, mac os 10.1

Verified that downloaded news mesgs are readable while offline.
Both in the mesg pane and in a stand alone window.

And non-downloaded mesgs aren't readable and display the proper
mesg.

Marking as verified.


Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.