GIF with no frame delay renders a white pixel

NEW
Unassigned
(NeedInfo from)

Status

()

Core
ImageLib
3 years ago
2 years ago

People

(Reporter: Lars Dɪᴇᴄᴋᴏᴡ, Unassigned, NeedInfo)

Tracking

34 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8535538 [details]
GIF with no frame delay

To reproduce:

Display attached image with Firefox 34.0.5. Since the browser defaults to rescale-to-window, click once to set image scaling to 1:1. Observe the colour of the pixel at coordinates 1313,892 relative to the top-left corner of the image.

Actual result:

Colour is white.

Expected result:

Colour should be a deep blue.


Further information:

This bug does not occur with Opera 12.16, Chromium 39.0.2171.65, gifview (from gifsicle 1.87).

When the GIF frame delay is changed from none to 1 centisecond each, Firefox renders the pixel correctly.
(Reporter)

Comment 1

3 years ago
Created attachment 8535539 [details]
GIF with 1 centisecond frame delay each

File contains the same encoded image data as above, just the frame delay is different.

Comment 2

3 years ago
It seems to be same between Firefox34 and IE11 on windows7x64.
I'm seeing the reported behavior using a recent build from hg tip (Firefox37.0a1 changeset 219326), on Ubuntu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
A recent regression?
Depends on: 1126330
Fixed in bug 1126330. We now play back the 0-frame-delay GIF just like Blink.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

2 years ago
Still broken in Firefox 44. Please retest.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Lars Dɪᴇᴄᴋᴏᴡ from comment #6)
> Still broken in Firefox 44. Please retest.

This looks fine on my end. Can you please provide more details?
(Reporter)

Comment 8

2 years ago
Created attachment 8717731 [details]
bug1110686.png

I don't know, what more details do you need?

Screenshot of the rendering defect highlighted with a pink circle attached.
(In reply to Lars Dɪᴇᴄᴋᴏᴡ from comment #8)
> Created attachment 8717731 [details]
> bug1110686.png
> Screenshot of the rendering defect highlighted with a pink circle attached.

Thanks, I can see the issue now on the GIF with no frame delay. I'm updating the summary to more accurately describe the issue. I'll see if I can track down if this was ever fixed and if so, what fixed it and what regressed it.
Summary: bad GIF rendering → GIF with no frame delay renders a white pixel
Status: REOPENED → NEW
Okay, so I've tested and reproduced the issue Firefox 44.0, 43.0, 42.0 and 41.0. I think it's safe to say that this issue was never fixed.

Seth, do you have any ideas as to what could be happening here?
Flags: needinfo?(seth)
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: gfx-noted
You need to log in before you can comment on or make changes to this bug.