running two profiles at once mixes themes, bookmarks button setting

VERIFIED DUPLICATE of bug 135137

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 135137
17 years ago
2 years ago

People

(Reporter: Niels Aufbau, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Steps to reproduce:

1. Quick Launch can be on or off.
2. Set your profile to use the Modern skin.
3. Create a new profile (I called mine "1") and set it to use the Classic skin.
4. Create three desktop shortcuts:
 a) mozilla.exe -P "Default User"
 b) mozilla.exe -P 1
 c) mozilla.exe
5. Open (a) and wait for it to load.
6. Open (b) and wait for it to load.


Result:

1. The new window appears with the Classic skin, but the first window is still
using the Modern skin.

2. If you now open a menu in the first window, it looks like a classic menu.

3. If the bookmarks button was disabled in your profile, it suddenly appears in
the first window just before the second window appears.
 a) This may indicate a perf bug.  Is the same code (which seems to be "go
through each open window, making sure it has a bookmarks button") executed each
time I open a new window or each time I launch Mozilla?
 b) Why does the bookmarks button appear but not the search button next to the
location bar?


Expected result:

A dialog should appear, telling me that I can't launch profile 1 until I've
closed all Default User windows.  

--or--

The second profile should be launched in a new process, not interfering with the
windows of the first profile.  (How would this interact with Quick Launch?)


Bug 101968, which involves using a single profile in Mozilla and in Netscape 6
simultaneously, may be related.
(Assignee)

Comment 1

17 years ago
Yes it's a problem but a quite unlikely one. Futuring.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

15 years ago
Dupe.

*** This bug has been marked as a duplicate of 135137 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
verified
Status: RESOLVED → VERIFIED
QA Contact: ktrina → gbush
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.