Last Comment Bug 1110881 - Google login popup gives no context
: Google login popup gives no context
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: GData (show other bugs)
: unspecified
: x86_64 Windows 8.1
-- normal (vote)
: 4.0.0.1
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
: 1136582 (view as bug list)
Depends on:
Blocks: 1117541
  Show dependency treegraph
 
Reported: 2014-12-12 09:08 PST by Kent James (:rkent)
Modified: 2015-02-28 04:47 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (4.83 KB, patch)
2015-01-03 05:42 PST, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
Fix - v1 (4.89 KB, patch)
2015-01-03 05:42 PST, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
Fix - v2 (4.88 KB, patch)
2015-01-21 03:49 PST, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
Fix - v2 (4.87 KB, patch)
2015-01-21 04:24 PST, Philipp Kewisch [:Fallen]
bv1578: review+
Details | Diff | Splinter Review
Fix - v3 (4.93 KB, patch)
2015-01-23 03:37 PST, Philipp Kewisch [:Fallen]
philipp: review+
Details | Diff | Splinter Review

Description User image Kent James (:rkent) 2014-12-12 09:08:05 PST
I assume that the latest version of the GData provider is what is now giving a popup window "Enter name and password for rkentjames@gmail.com"

This window has no hint as to why it is being requested. I can only assume that it has something to do with this addon. It is really not acceptable to just have a screen popup asking for credentials, without any hint as to why they are wanted.
Comment 1 User image Philipp Kewisch [:Fallen] 2014-12-15 15:22:35 PST
This is no different with the Filelink OAuth window when it appears, but that doesn't mean it shouldn't be fixed. I guess I could add a <description> at the top of the browser window being shown describing the circumstances.
Comment 2 User image kossem 2014-12-29 02:29:27 PST
A description would be an excellent addition, also to help debug the multiple master password dialog boxes irritating problem...
Comment 3 User image Philipp Kewisch [:Fallen] 2015-01-03 05:42:00 PST
Created attachment 8543497 [details] [diff] [review]
Fix - v1
Comment 4 User image Philipp Kewisch [:Fallen] 2015-01-03 05:42:56 PST
Created attachment 8543498 [details] [diff] [review]
Fix - v1
Comment 5 User image Philipp Kewisch [:Fallen] 2015-01-21 03:47:10 PST
Comment on attachment 8543498 [details] [diff] [review]
Fix - v1

Mohit, I'm moving around the reviews a bit so not all of the requests are on your shoulders :)
Comment 6 User image Philipp Kewisch [:Fallen] 2015-01-21 03:49:32 PST
Created attachment 8552398 [details] [diff] [review]
Fix - v2

Oh and I needed to debitrot the patch
Comment 7 User image Philipp Kewisch [:Fallen] 2015-01-21 04:24:29 PST
Created attachment 8552421 [details] [diff] [review]
Fix - v2
Comment 8 User image Decathlon 2015-01-23 02:01:41 PST
Comment on attachment 8552421 [details] [diff] [review]
Fix - v2

Review of attachment 8552421 [details] [diff] [review]:
-----------------------------------------------------------------

It works fine and the message in description seems complete for the use.

I would add only a bit of margin on the bottom of the #dialogMessage element so that the message would appear vertical centered in the box.

::: calendar/locales/en-US/chrome/calendar/providers/gdata/gdata.properties
@@ +47,5 @@
>  # LOCALIZATION NOTE (syncStatus):
>  # %1$S = The name of the calendar that is being synchronized
>  syncStatus=Synchronizing Calendar %1$S
> +
> +# %1$S - The session id (email) used for authentication

Here you could add the LOCALIZATION NOTE header just to make the block the same as the other in the file.
Comment 9 User image Philipp Kewisch [:Fallen] 2015-01-23 03:37:22 PST
Created attachment 8553683 [details] [diff] [review]
Fix - v3

Thanks, all comments taken care of :)
Comment 10 User image Philipp Kewisch [:Fallen] 2015-01-27 16:14:35 PST
Pushed to comm-central changeset 84fa89be5232
Comment 11 User image Philipp Kewisch [:Fallen] 2015-02-28 04:47:14 PST
*** Bug 1136582 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.