Sound constantly stop working after a while for any multimedia content

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: c_moi_l_master, Unassigned)

Tracking

34 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Recently, I have trouble with firefox. It was using too much cpu, too much ram, freezing like hell, refresh bug etc so I decided to take care of the problem, I eventually found out Avast was responsible for the freeze/cpu/ram usage, and as of now, those problems are essentially gone (thanks to disabling Avast's web agent).
I have others issues though.
Sound stops playing after a while, in any situation, if I start firefox, no matter which multimedia I'm using and no matter which technology are involved (javascript, flash player), sound just randomly stop playing and the only way to get it back is to close/reopen. I also have a refresh issue, 10% of the time, when i click on a tab to activate it, its content is not refreshed correctly, like mouse hovering controls will slowly get them to be shown but not perfectly, activating a different tab is required (back and forth if I want the one which glitched).
I made a new profile already, I reinstalled firefox already, I tried safe mode, I deleted all extentions/plugins, only the cisco's default codec is there now.
I scanned the whole computer for virus and such, used adwcleaner to remove anything that could be an issue, I still have no sound and I still get refreshing issue.
I have the latest driver for my graphic card, I have hardware acceleration disabled, I have a blank/clean firefox.


Actual results:

Sounds stops working after a while.
Tabs are not refreshing properly, occasionally
A concrete example of something incorrect happening is watching a video on youtube. If i pause the video, scroll (the buffer), play, pause, scroll etc, it will make the sound not working much sooner than if i never pause the video


Expected results:

Sound should be working.
Tabs should be refreshed correctly.
This cisco codec seems to be able to play any multimedia and since I thought flash could be a problem, I keep flash uninstalled. Note that the sound is not working the same with or without flash installed.
(Reporter)

Comment 1

4 years ago
Hum, after a bit of investigation it does not seem to be related to firefox itself, it's an audiodg.exe issue, however I don't get audiodg.exe to use that much cpu when the sound stops working and I don't get sound in itunes to stop for example (I suspect itunes plays sound without audiodg.exe but I read that any sound is played thanks to audiodg now so...)

Comment 2

4 years ago
I am getting this same issue and it is extremely annoying.

After Firefox is running for awhile, most sounds cease functioning including other sounds for unrelated applications running on the Operating System. Restarting Firefox will fix it for a short time until it breaks again. Running FF 34.0.5

I do not have any audiodg.exe processes running on my system.

This issue only started occurring after upgrading to FF 34.
(Reporter)

Comment 3

4 years ago
I do have audiodg.exe, I already tried disabling All enhancements in the properties, it doesn't help, but audiodg.exe does not take much cpu here, not even more than 5% (I had some troubles with it at first but it wasn't more than 10-12% of cpu usage) but since I completely disabled avast, it's not using much cpu. I tried using html5 on youtube, I guess that helped a bit but I'm sure i can still reproduce this issue with youtube video. Typically I start a video, there is no sound, whenever I scroll in the buffer, it alternates: one click = no sound, one more click = sound, one more click = no sound
The main problem for me is with chess.com, their live chess application is a mix of javascript and flash and there, at first I get the sound, and the more the time pass, the more the sound disappear.

So I tried chrome for a change, on this chess.com live stuff, guess what, audiodg.exe is at 12-14% and i get all the sound, naturally I always get the sound on any video with chrome.

Yelplok, audiodg.exe is running as a local service, on the task manager, click the 'show processes from all users' see if you get audiodg.exe there (it's part of windows, you should, i believe)
(Reporter)

Comment 4

4 years ago
Oops I forgot I already said I had audiodg.exe running, I thought I didn't talk about that. I do not get sound in others programs such as itunes to stop, only firefox is affected, my antivirus Avast is completely disabled. In case my config matters, I have an amd phenom ii x4 965 at 3.4ghz with 4gb of ram, integrated video card uses 256mb if i'm not mistaken, running windows 7 pro 64 bits

Comment 5

4 years ago
I have the 'AudioSrv' service for 'Windows Audio'. Also Windows 7 Pro x64. I'm seeing lots of similar reports such as:
http://www.reddit.com/r/firefox/comments/2pfohn/no_html5_sound/
http://www.reddit.com/r/firefox/comments/2p5rto/sound_issues_after_the_latest_update/
(Reporter)

Comment 6

4 years ago
This link are not related, it's not about html5, I just opened a youtube link, sound worked, I scrolled/browsed in the buffer to go from 00:00:07 to like 00:00:35 and sound stopped, I rescrolled somewhere else and sound was back, I do not get any crash of firefox or flash. It does not happen after firefox has been running for some time, it happens as soon as I want to reproduce lol.
(Reporter)

Comment 7

4 years ago
Ok, after some more investigations, this is definitely a driver issue on MY end.

I can reproduce the issue with Chrome and in fact playing sound in Itunes (which wasn't a problem) made audiodg.exe take 18% of cpu..

Well when all those problems started, I tried updating audio drivers of course but I'm not sure If I had these two (see below) before trying to update or not:

I had/have 3 playback devices listed when I right click the sound icon in the tray and select 'playback devices', the one for my main speakers, which is also the one used when I plug headphone on the front interface of the case, listed as "Speakers, VIA high definition audio, default device" and two others, listed as "SPDIF Inteface Tx0" and "SPDIF Interface Tx1".

Well I don't know what those last two are in reality, google helped a bit saying it's a standard used to numerically store audio from one device to another, something probably handled/supported by my soundcard/motherboard/driver but I do not have an use for it. I noticed that whenever sound was playing but I couldn't hear anything, the Tx0 interface reported that it was being used so I disabled both Tx0 and Tx1, and the sound is working as expected. So it's probably a problem with the driver, I had hard time finding the last up to date driver so I may have ended up installing the wrong one, or one that is faulty anyway. I can't bother to try to find a different driver for now so I'll keep these two disabled until it's a problem, hopefully it's never going to be a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.