[Text Selection] Cut/Copy/Paste menu does not dismiss when deleting selected text

VERIFIED FIXED in 2.2 S3 (9jan)

Status

()

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: AdamA, Assigned: gduan)

Tracking

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing], )

Attachments

(4 attachments)

Posted file logcat
Description:
When a user long presses to select text the "Cut/Copy/Paste" menu will appear. If the user then deletes the selected text this menu will not go away. the menu will not go away until the user selects other text to copy and a new menu appears.

Repro Steps:
1) Update a Flame to 20141212040206
2) Enter contacts
3) Choose to create a new contact
4) Long press the entered text
5) When the menu appears delete the higlighted text
6) Observe menu still being present

Actual:
The Cut/Copy/Paste menu will not disappear after deleting selected text

Expected:
It is expected that the menu dismisses when selected text is deleted

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141212040206
Gaia: 1d9ae9cca415ad093beba9521c429350e1f2b14d
Gecko: 5288b15d22de
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5
See attached: video clip, logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Needinfo on QA Lead for blocker nomination, not a regression.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI developer for this.
Flags: needinfo?(gchang) → needinfo?(gduan)
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][ft:system-platform]
blocking-b2g: --- → 2.2?
Another sychronization between selectioncarets and text dialog.
When problem happened, I also saw selectionchanged with no_reason.

I/PRLog   (14702): -1225273004[b6a4a080]: SelectionCarets (b2fa1470): NotifySelectionChanged:1126 : aSel (b3dcbd40), Reason=0
I/PRLog   (14702): -1225273004[b6a4a080]: SelectionCarets (b2fa1470): SetVisibility:299 : Set visibility hidden
Flags: needinfo?(gduan) → needinfo?(mtseng)
As comment 3, gaia would not receive this selectionchanged event to hide the bubble. Let ni to gecko guy first.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][textselection]
Component: Gaia::System → Selection
Product: Firefox OS → Core
Whiteboard: [2.2-Daily-Testing][ft:system-platform] → [2.2-Daily-Testing]

Comment 5

5 years ago
ni George for verify if the bug still exists.
Flags: needinfo?(gduan)

Updated

5 years ago
Priority: -- → P2
The pb still exists.

When launching the bubble and tap on the keyboard, I will receive a selectionstatechanged event with no states which gaia ignore it. However, I think we should put a "blur" inside it to hide the bubble.

And one more pb,
after tapping the keyboard, the bubble is still there, and then I try to tap any place(including input field) of foreground app, the bubble cannot be closed.
Flags: needinfo?(gduan)
Posted file PR to master
Hi Alive,
could you review this patch?
I also remove scrollend event listener due to bug 1114853 is landed.
Attachment #8544321 - Flags: review?(alive)
Attachment #8544321 - Flags: review?(alive) → review+
Clear ni since patch has been provided.
Flags: needinfo?(mtseng)
Thanks,
merged to master: https://github.com/mozilla-b2g/gaia/commit/c56dd67573a5f993a364ddc441339ec46e45d22e
Assignee: nobody → gduan
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8544497 [details] [review]
PR to master, marionette test

Add marionette test for this bug.
Attachment #8544497 - Flags: review?(alive)
Attachment #8544497 - Flags: review?(alive) → review+
Duplicate of this bug: 1117684

Comment 14

5 years ago
Triage: blocker.
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage+][textselection] → [QAnalyst-Triage+][COM=Text Selection]
Target Milestone: --- → 2.2 S3 (9jan)
Posted video v2.2.3gp
This bug has been verified as pass on latest build of Flame v2.2 by the STR in Comment 0. 

Results:
The "Cut/Copy/Paste" menu dismisses when selected text is deleted in Contacts app.

Attachment:v2.2.3gp
Rate:0/20

Device: Flame 2.2 (Verified)
Build ID               20150702162501
Gaia Revision          2d6cbec3a4004bb770ecbadbba83f86b95365e56
Gaia Date              2015-07-02 13:40:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b465f8d7254f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150702.195016
Firmware Date          Thu Jul  2 19:50:27 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.