Closed Bug 1111014 Opened 5 years ago Closed 4 years ago

crash in AudioMixer::FinishMixing

Categories

(Core :: Web Audio, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1181735

People

(Reporter: suburp212, Unassigned)

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

May be a variant of
https://bugzilla.mozilla.org/show_bug.cgi?id=1067555
or
https://bugzilla.mozilla.org/show_bug.cgi?id=1059585

Was running http://www.klassikradio.de/liveplayer.php (stable for days, usually), and started some flash game in a second tab
https://www.bahnbonus-saemmeln.de/#/start



Actual results:

just when I hit start, all crashed.
On analysis, though, it looks like the web audio caused the problem, and the other tab was just coincidence.
Interestingly, there appears to be no red flag in the crashing thread
https://crash-stats.mozilla.com/report/index/b7e5ab34-a2ee-4d35-94e1-2e7392141212

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::AudioMixer::FinishMixing() 	content/media/AudioMixer.h
1 	xul.dll 	mozilla::MediaStreamGraphImpl::Process(__int64, __int64) 	content/media/MediaStreamGraph.cpp
2 	xul.dll 	mozilla::MediaStreamGraphImpl::OneIteration(__int64, __int64, __int64, __int64) 	content/media/MediaStreamGraph.cpp
3 	xul.dll 	mozilla::AudioCallbackDriver::DataCallback(float*, long) 	content/media/GraphDriver.cpp
4 	xul.dll 	mozilla::AudioCallbackDriver::DataCallback_s(cubeb_stream*, void*, void*, long) 	content/media/GraphDriver.cpp
5 	gkmedias.dll 	noop_resampler::fill(void*, long) 	media/libcubeb/src/cubeb_resampler.cpp
6 	gkmedias.dll 	`anonymous namespace'::refill(cubeb_stream*, float*, long) 	media/libcubeb/src/cubeb_wasapi.cpp
7 	gkmedias.dll 	`anonymous namespace'::wasapi_stream_render_loop 	media/libcubeb/src/cubeb_wasapi.cpp
8 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
9 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
10 	kernel32.dll 	BaseThreadInitThunk 	
11 	ntdll.dll 	__RtlUserThreadStart 	
12 	ntdll.dll 	_RtlUserThreadStart



Expected results:

Configuration:

Name 	Firefox
Version 	34.0
Update History 	
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Profile Folder 	
Enabled Plugins 	about:plugins
Build Configuration 	about:buildconfig
Memory Use 	about:memory
Multiprocess Windows 	0/1
Crash Reports for the Last 3 Days
Report ID 	Submitted
bp-b7e5ab34-a2ee-4d35-94e1-2e7392141212	31 minutes ago

All Crash Reports
Extensions
Name 	Version 	Enabled 	ID
Adblock Plus	2.6.6	true	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Amazon Shopping Assistant by Spigot	2.0	true	{DE1C78C1-2762-47f6-A1D9-1B7866FE7EB4}
Ebay Shopping Assistant by Spigot	2.0	true	{CA8C84C6-3918-41b1-BE77-049B2BDD887C}
Greasemonkey	2.3	true	{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
LastPass	3.1.1	true	support@lastpass.com
Lazarus: Form Recovery	2.3	true	lazarus@interclue.com
NoScript	2.6.9.6rc3	true	{73a6fe31-595d-460b-a920-fcc0f8843232}
Personas Plus	1.7.3	true	personas@christopher.beard
Slick Savings	3.5	true	{54FBE89E-C878-46bb-A064-AB327EE26EBC}
Start Page	2.6	true	{62DD0A97-FDD4-421b-94A5-D1A9434450C7}
Xmarks	4.3.6	true	foxmarks@kei.com
YouTube Center	2.1.0	true	jid1-cwbvBTE216jjpg@jetpack
ChatZilla	0.9.91	false	{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}
FireFTP	2.0.21	false	{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
Flashblock	1.5.18	false	{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Multi Links	3.0.0.19	false	multilinks@plugin
Skype Click to Call	6.9.0.12585	false	{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Graphics
Adapter Description	ATI Mobility Radeon HD 5730
Adapter Drivers	atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	1024
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x68c0
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	1-22-2010
Driver Version	8.692.1.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	02fe1028
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Mobility Radeon HD 5730 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Important Modified Preferences
Name 	Value accessibility.typeaheadfind.flashBar	0
browser.cache.disk.capacity	358400
browser.cache.disk.smart_size.first_run	false
browser.cache.disk.smart_size.use_old_max	false
browser.cache.frecency_experiment	4
browser.places.smartBookmarksVersion	7
browser.sessionstore.upgradeBackup.latestBuildID	20141125180439
browser.startup.homepage_override.buildID	20141125180439
browser.startup.homepage_override.mstone	34.0
browser.tabs.warnOnClose	false
dom.mozApps.used	true
extensions.lastAppVersion	34.0
gfx.direct3d.last_used_feature_level_idx	0
media.gmp-gmpopenh264.lastUpdate	1414431694
media.gmp-gmpopenh264.version	1.1
media.gmp-manager.lastCheck	1418417536
network.cookie.prefsMigrated	true
places.database.lastMaintenance	1418415114
places.history.expiration.transient_current_max_pages	104858
plugin.disable_full_page_plugin_for_types	application/pdf
plugin.importedState	true
privacy.cpd.offlineApps	true
privacy.donottrackheader.enabled	true
privacy.sanitize.migrateFx3Prefs	true
privacy.sanitize.timeSpan	0
storage.vacuum.last.index	1
storage.vacuum.last.places.sqlite	1417191944
Important Locked Preferences
	Name 	Value
JavaScript
Incremental GC 	true
Accessibility
Activated 	false
Prevent Accessibility 	0
Library Versions
	Expected minimum version	Version in use
NSPR	4.10.7	4.10.7
NSS	3.17.2 Basic ECC	3.17.2 Basic ECC
NSSSMIME	3.17.2 Basic ECC	3.17.2 Basic ECC
NSSSSL	3.17.2 Basic ECC	3.17.2 Basic ECC
NSSUTIL	3.17.2	3.17.2
Experimental Features
Name 	ID 	Description 	Active 	End Date 	Homepage
Crashing raw dump

 "crash_info": { "address": "0x5a5a5a5a", "crashing_thread": 140, "type": 

"EXCEPTION_ACCESS_VIOLATION_READ" },


 "crashing_thread": { "frames": [ { "file": "hg:hg.mozilla.org/releases/mozilla-release:content/media/AudioMixer.h:456394191c90", "frame": 0, "function": "mozilla::AudioMixer::FinishMixing()", "function_offset": "0x21", "line": 68, "module": "xul.dll", "module_offset": "0xb348be", "offset": "0x656348be", "registers": { "eax": "0x5a5a5a5a", "ebp": "0x23e6f73c", "ebx": "0x137ab8f0", "ecx": "0x2a46d058", "edi": "0x225571f0", "edx": "0x277f9008", "efl": "0x00010202", "eip": "0x656348be", "esi": "0x217ecfc0", "esp": "0x23e6f6ec" }, "trust": "context" }, { "file": "hg:hg.mozilla.org/releases/mozilla-release:content/media/MediaStreamGraph.cpp:456394191c90", "frame": 1, "function": "mozilla::MediaStreamGraphImpl::Process(__int64,__int64)", "function_offset": "0x14f", "line": 1367, "module": "xul.dll", "module_offset": "0x110694f", "offset": "0x65c0694f", "trust": "cfi_scan" }, { "file": "hg:hg.mozilla.org/releases/mozilla-release:content/media/MediaStreamGraph.cpp:456394191c90",
Are you able to reproduce the crash?
Severity: normal → critical
Crash Signature: [@ mozilla::AudioMixer::FinishMixing() ]
Keywords: crash
Summary: AudioMixer::FinishMixing() → crash in mozilla::AudioMixer::FinishMixing()AudioMixer::FinishMixing()
Summary: crash in mozilla::AudioMixer::FinishMixing()AudioMixer::FinishMixing() → crash in AudioMixer::FinishMixing
(In reply to Loic from comment #2)
> Are you able to reproduce the crash?

not yet. Tried to access violate my brwoser again, but couldn't, yet.
Group: core-security
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181735
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.