Make MobileConnectionCallback consistently async

RESOLVED DUPLICATE of bug 1070831

Status

RESOLVED DUPLICATE of bug 1070831
4 years ago
4 years ago

People

(Reporter: pgravel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Most MobileConnectionCallback function have a built-in asynchronous step, except for the error cases that result in FireDetailedError, which makes behavior a little inconsistent when issuing callbacks.
http://mxr.mozilla.org/mozilla-central/source/dom/mobileconnection/MobileConnectionCallback.cpp#387

Requesting that an async step be added for the error callbacks that use FireDetailedError()

Updated

4 years ago
Blocks: 1063044
(In reply to pgravel from comment #0)
> Most MobileConnectionCallback function have a built-in asynchronous step,
> except for the error cases that result in FireDetailedError, which makes
> behavior a little inconsistent when issuing callbacks.
> http://mxr.mozilla.org/mozilla-central/source/dom/mobileconnection/
> MobileConnectionCallback.cpp#387
> 
> Requesting that an async step be added for the error callbacks that use
> FireDetailedError()

Hi,
The section of code is going to be removed in https://bugzilla.mozilla.org/attachment.cgi?id=8536486
After that, I think your concern will be released.
I am going to close this bug as duplicate of bug 1070831. Feel free to reopen it if i misunderstand something or you disagree, thank you.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070831

Updated

4 years ago
blocking-b2g: 2.2? → ---

Updated

4 years ago
No longer blocks: 1063044
You need to log in before you can comment on or make changes to this bug.