Cannot install new Dictionary for Thunderbird (Thunderbird ask to download instead of installing XPI from https://addons.mozilla.org/)

RESOLVED DUPLICATE of bug 1049157

Status

RESOLVED DUPLICATE of bug 1049157
4 years ago
4 years ago

People

(Reporter: Dpeelen, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Tried to install a new dictionary.

Go to Options->Spelling->Click "Download more dictionaries"->go to https://addons.mozilla.org/nl/thunderbird/language-tools/ -> Click a dictionary-> Click Download now.


Actual results:

Got a popup asking what program to use with file. When using Thunderbird, it adds the xpi as a attachment to a new email.


Expected results:

It should have Installed the dictionary (with no restart).

Additional details:

When i download the xpi and drag it into the add-on manager, it install the dictionary normally (without restart).
(Reporter)

Comment 1

4 years ago
Update: Confirmed for 36.0a2 (2014-12-12) also.

Also, it's Options->Composition->Spelling->Download More Dictionaries.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049157
(Reporter)

Comment 3

4 years ago
This still doesn't work for me in 31.3.0 or 36.0a2 (2014-12-24), that bug you marked duplicate is said to be resolved for those versions. Therefore this is either a different bug or the old one should be reopened.

Please notice: It does give a download pop-up, one you get when you download a file (the other bug said it gave nothing at all, not even the option to download the xpi).

What i expect is a dialog that ask if i want to install the dictionary/xpi. Right now i can only Save the file locally, or open it with a program. But when you open it with Thunderbird, it tries to attach it to a email (useless).

Rather, you need to save it, find the download folder, and drag it back into the add-on manager. This is a bit clumsy. Not to mention these steps end with a warning box "Installed add-ons from authors whom you trust. Malicious software can damage your computer or violate your privacy." This is all not very appealing to the average user. Not to mention hard to figure out.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
No, bug 1081190 only landed for unreleased versions of thunderbird 37 or 31.4.0 so far.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049157
You need to log in before you can comment on or make changes to this bug.