[Bluetooth] The user is not informed when a paired device unpairs

RESOLVED DUPLICATE of bug 1066461

Status

RESOLVED DUPLICATE of bug 1066461
4 years ago
4 years ago

People

(Reporter: smiko, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8535908 [details]
SendingDevice.txt

Description:
When a paired user unpairs their device, the other user is not notified and can still attempt to send files. No error message is displayed.

Repro Steps:
1: Update a Flame to 20141212040206.
2: Pair two Flame devices.
3: On one of the devices, open Settings > Bluetooth > unpair.
4: On the other device attempt to send an image to the unpaired device.

Actual: The file appears to transfer. The transfer starts but does not progress. 

Expected: The sender is notified that the receiver is no longer paired. 

Environmental Variables:
Device: Flame 2.2
BuildID: 20141212040206
Gaia: 1d9ae9cca415ad093beba9521c429350e1f2b14d
Gecko: 5288b15d22de
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5

See attached: logcat
(Reporter)

Comment 1

4 years ago
QA Wanted for branch checks
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Keywords: qawanted

Comment 2

4 years ago
Receiver is allowed to receive file from an unpaired device since 2.2 UX spec, per bug 1066461 comment 14. Set duplicate to bug 1066461 since this bug disappears once bug 1066461 is fixed. Feel free to reopen for any further concern.

Note sender cannot know receiver's unpairing when receiver unpairs since the receiver does it locally. Not until sender interacts with receiver (e.g., transfer file) does sender become aware of the unpairing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066461
Removing qawanted since this issue is a duplicate.
Flags: needinfo?(ktucker)
Keywords: qawanted
Resolution: DUPLICATE → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
resetting duplicate resolution.
Flags: needinfo?(pbylenga)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1066461
You need to log in before you can comment on or make changes to this bug.