If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TEST-UNEXPECTED-FAIL | simple-prefs/main.testAOM | Test timed out (after: START)

RESOLVED DUPLICATE of bug 1111102

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 1111102
3 years ago
3 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

https://tbpl.mozilla.org/php/getParsedLog.php?id=54447033&tree=Jetpack&full=1#error0

s passed.
Total time: 3.102282 seconds
Program terminated successfully.
Testing simple-prefs...
Warning: missing module: resource://gre/modules/AddonManager.jsm
Warning: missing module: resource://gre/modules/Preferences.jsm
Warning: missing module: ../../framescript/FrameScriptManager.jsm
Using binary at '/builds/slave/talos-slave/test/addonsdk-poller/Nightly.app/Contents/MacOS/firefox-bin'.
Using profile at '/var/folders/xN/xNHO3c9YHLydA+emES-hJE+++-k/-Tmp-/tmpqVSvNj.mozrunner'.
2014-12-11 23:54:40.039 firefox-bin[1282:903] *** __NSAutoreleaseNoPool(): Object 0x100404db0 of class NSCFDictionary autoreleased with no pool in place - just leaking
2014-12-11 23:54:40.042 firefox-bin[1282:903] *** __NSAutoreleaseNoPool(): Object 0x100405280 of class NSCFArray autoreleased with no pool in place - just leaking
console.info: simple-prefs: hiddenWindow document.documentURI:chrome://browser/content/hiddenWindow.xul
console.info: simple-prefs: hiddenWindow document.readyState:complete
Running tests on Firefox 37.0a1/Gecko 37.0a1 ({ec8030f7-c20a-464f-9b0e-13a3a9e97384}) under darwin/x86_64.
TEST-START | simple-prefs/main.testAOM
JavaScript error: chrome://mozapps/content/extensions/extensions.js, line 719: NS_ERROR_FAILURE: Invalid view: detail
TEST-INFO | [JavaScript Error: "NS_ERROR_FAILURE: Invalid view: detail" {file: "chrome://mozapps/content/extensions/extensions.js" line: 719}]
TEST-UNEXPECTED-FAIL | simple-prefs/main.testAOM | Test timed out (after: START)
TEST-INFO | Traceback (most recent call last):
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/timers.js", line 40, in notify
    callback.apply(null, args);
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 473, in tiredOfWaiting
    self.console.testMessage(false, false, self.test.name,
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/test/harness.js", line 547, in testMessage
    this.trace();
TEST-UNEXPECTED-FAIL | simple-prefs/main.testAOM | Should not be any unexpected tabs open
TEST-INFO | Traceback (most recent call last):
  File "resource://gre/modules/Promise-backend.js", line 691, in this.PromiseWalker.scheduleWalkerLoop/<
    DOMPromise.resolve().then(() => this.walkerLoop());
  File "resource://gre/modules/Promise-backend.js", line 749, in this.PromiseWalker.walkerLoop
    this.handlers.shift().process();
  File "resource://gre/modules/Promise-backend.js", line 870, in Handler.prototype.process
    nextValue = this.onResolve.call(undefined, nextValue);
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 327, in done/<
    this.fail("Should not be any unexpected tabs open");
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 98, in fail
    this.console.testMessage(false, false, this.test.name, message);
  File "resource://extensions.modules.test-simple-prefs-at-jetpack.commonjs.path/sdk/test/harness.js", line 547, in testMessage
    this.trace();
TEST-INFO | Windows open:
TEST-INFO | chrome://bro
Keywords: intermittent-failure
Blocks: 1111478, 790323
Depends on: 1093034
No longer depends on: 1093034
Blocks: 1114752
I think this is resolved with bug 1111102
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1111102
You need to log in before you can comment on or make changes to this bug.