Sign in window launches even if already signed in

RESOLVED WORKSFORME

Status

Webmaker
webmaker.org
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Mahir Labib Chowdhury, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141212004002

Steps to reproduce:

1. Go to webmaker.org
2. Log in with persona
3. Scroll a little
4. Click "Sign In"


Actual results:

Clicking the Sign In button opens a new Persona Log In Window and If you click sign in is repeats the processes.


Expected results:

The Button shouldn't work, or Persona Shouldn't repeat the Log In processes again!
It looks like fine here, can you please add a screenshot or something to review :)
Created attachment 8536009 [details]
Sign In Button

I am confirming the Bug as I can reproduce by following STR

# Go to www.webmaker.org
# Click on The "Sign In" Button which is in the above.
# A window will come to login with Persona Account
# Login with your persona account
# Come to the Webmaker Page
# You will see that you have logged in
# Scroll down in the page
# You will see another "Sign In" in the section as per the attachment.

Expected Result:
As you have already logged in, you should not see another "Sign In" Button after logged in.
Looks like, it's throughout the site on every single page where you see a join or login or sign in button. All are using same logic that means now you have submitted a bug which needs a huge amount of review. 

This might be an easy simple solution, we can add a common class on every single button regarding JOIN, LOGIN and SIGN IN and then whenever the sign in occurs all those class will have an display: none; using Javascript :)
(Reporter)

Comment 4

4 years ago
I found this only on the landing page, can you get me the links of other pages?
Flags: needinfo?(anistuhin)
https://webmaker.org/en-US/signup Got this one.
Flags: needinfo?(anistuhin)
(Reporter)

Comment 6

4 years ago
(In reply to Md. Anisur Rahman from comment #5)
> https://webmaker.org/en-US/signup Got this one.

I wonder, what could be the purpose of a Log In button is a Sign Up page where user came to join!
If someone visits from the browser suggestion :)

Comment 8

4 years ago
This is currently a bug the login 2.0 system, where you could easily open multiple Persona pop-ups. Want to try doing the same thing on our login 3.0 system, on https://webmaker.mofostaging.net ?

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

4 years ago
Jon,
The site you provided seems fine. That certainly doesn't have this problem. Dying to see that in action for public. And the UI enhancement is also better.
(Reporter)

Comment 10

4 years ago
Created attachment 8539428 [details]
irrelevent.PNG

Since I'm already logged in, do we really need to provide this area?
Flags: needinfo?(jon)
(Reporter)

Comment 11

4 years ago
And if I click the Start Creating Button at the end of the page, I'm provided with a area to enter my email and join again! PS: I'm already logged in
This is now resolved since we have changed to the new login and we don't display that signin with persona on the home page anymore
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Flags: needinfo?(jon)
You need to log in before you can comment on or make changes to this bug.