Last Comment Bug 1111277 - (BPG) Better Portable Graphics (BPG) support
(BPG)
: Better Portable Graphics (BPG) support
Status: RESOLVED WONTFIX
: feature
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: All All
-- enhancement with 44 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
http://bellard.org/bpg/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-13 13:57 PST by Djfe
Modified: 2016-01-31 09:39 PST (History)
35 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Djfe 2014-12-13 13:57:33 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439




Expected results:

Will the Better Portable Image format (BPG) be supported in the future?

It seems to be an awesome image compression format.

It's based on HVEC (Main 4:4:4 16 Still Picture Profile, Level 8.5 to be specific).

It's compression is superior to JPEG in many ways.

It supports alpha channels and several color spaces and 8 to 14 bits per color channel.
You can even choose between lossy and lossless compression.

The decoder is either available with LGPL License (FFMPEG) or BSD.
The encoder is only available with BSD (or GPL if you choose x265).

Decoding is possible with a little bit of Javascript code.

it supports lots of metadata as well.

http://bellard.org/bpg/
Comment 1 User image Djfe 2014-12-22 12:42:14 PST
Can somebody/one of the devs pls give some feedback on my request.
Is it a desired feature or is it questionable.

I mean of course the format hasn't established itself, yet, because it's new.
But Mozilla could at least implement and support it in the future, so that it's not in the way.

I don't want it implemented tomorrow, of course.

I just would like to get a response. (I get notifications of people that subscribed to this thread all the time, but no replies from them...)
Comment 2 User image Binyamin 2015-01-15 10:10:38 PST
Source in Github https://github.com/thomas-huet/libbpg
Comment 3 User image Seth Fowler [:seth] [:s2h] 2015-01-15 12:16:46 PST
At this time, to my knowledge, no one at Mozilla has had a chance to make a thorough evaluation of BPG from a technical perspective. We are definitely paying attention, but it's going to take a while.

Implementing a new image format is a big commitment for a variety of reasons, so we have to be cautious and think things through before doing it.
Comment 4 User image Djfe 2015-01-15 13:06:10 PST
ok, cool :)
Comment 5 User image Abhishek Modi 2015-10-28 09:08:55 PDT
Wait this is excellent. I'd love to take this on :)
Comment 6 User image Peter 2015-10-28 15:36:12 PDT Comment hidden (me-too)
Comment 7 User image gilman31 2015-10-29 15:54:12 PDT Comment hidden (me-too)
Comment 8 User image rained23 2015-10-29 23:17:37 PDT Comment hidden (me-too)
Comment 9 User image Florens Verschelde 2015-10-30 02:47:49 PDT
HEVC is patent-protected, and apparently there are two patent pools as potential licensors (MPEG LA and HEVC Advance). This probably means that Firefox can't bundle BPG support, and might only rely on a codec plugin like it does with Cisco’s OpenH264 plugin. Of course that would mean it would need a third-party to offer to pay the license costs like Cisco does for H264 now.

Wikipedia (maybe not the most accurate source) also writes that "The HEVC Advance license has a maximum royalty rate of US$2.60 per device for Region 1 countries and a content royalty rate of 0.5% of the revenue generated from HEVC video services."
If I'm reading this correctly, sites serving BPG would need to pay some of their revenue to HEVC Advance.

This format, like any codec, needs a legal review in addition to a technical review.
Comment 10 User image Mikhail 2016-01-23 08:29:28 PST
+1 for bpg format. Because it much better than webp, need prove?
Ok, look at here: http://xooyoozoo.github.io/yolo-octo-bugfixes/#moscow&webp=s&bpg=s
Comment 11 User image Tanel Eero 2016-01-26 09:34:41 PST Comment hidden (me-too)
Comment 12 User image Alex Art 2016-01-26 11:01:47 PST
(In reply to Tanel Eero from comment #11)
> +1 for this feature

You can simply vote for this feature.
However voting affects nothing :D WebP has 167 votes. Input type=date more then 100 and no one cares :(
Comment 13 User image Thomas Daede [:TD-Linux] 2016-01-26 15:53:12 PST
The licensing costs for HEVC makes implementing BPG in Firefox impractical.

In addition, supporting a patent encumbered image format is not in line with Mozilla's goals of promoting the free and open web.

BPG's technical performance is impressive, but a successor to JPEG needs to not regress on the freedom of usage that JPEG offers.
Comment 14 User image Jyrki Alakuijala 2016-01-31 07:43:22 PST
FLIF's testing shows that BPG is not superb on lossless compression.

https://docs.google.com/spreadsheets/d/1LxY78fbm47VmrYGTXkBXXitGjhGl32NsuHPH2QXufgA/edit#gid=751305882

Note You need to log in before you can comment on or make changes to this bug.