Get wrong pages when using a proxy

RESOLVED DUPLICATE of bug 38488

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 38488
17 years ago
17 years ago

People

(Reporter: Marijn Deé, Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have problem with the combination of a local proxy and the back button and
found Bug 60708 to describe my problem. But when I tried to reproduce the
problem I found that it worked a little different for me.

These are the steps to reproduce from 60708:

----8<----
Steps to Reproduce:
(you have to be using proxy server, cache has to be set at once per session)
1.Go to google.com, search for slashdot.
2.Follow link to slashdot
3.Click back button.
----8<----

I found that in step 2. clicking the link to slashdot took me back to the
google.com homepage. I use a JunkBuster proxy on my own computer that connects
to the company proxy (Squid). If I bypass the local proxy everything works fine.

Comment 1

17 years ago
1: Which build ID are you testing with?
2: Have you read the release notes about proxies?
http://www.mozilla.org/releases/mozilla0.9.6/#general
(Reporter)

Comment 2

17 years ago
Mozilla 9.6.0

I the proxy bit in the release notes. Setting HTTP version to 1.0 fixed the
problem, Thanks.

Marijn
junkbuster is broken and you must use http/1.0
You can't see this problem with IE because IE use for all Proxys http/1.0 and
Netscape 4.7x can only http/1.0


*** This bug has been marked as a duplicate of 38188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
i suck...

*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.