Jump to definition incorrectly resolves to header file declaration in elasticsearch branch

RESOLVED DUPLICATE of bug 986522

Status

RESOLVED DUPLICATE of bug 986522
4 years ago
3 years ago

People

(Reporter: archgoon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.99 KB, application/zip
Details
(Reporter)

Description

4 years ago
Created attachment 8536205 [details]
bug_example.zip

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

On the es branch, using the test_basic as a scaffold, unzip bug_example.zip into the directory, and modify dxr.config.in to use bug_example instead of code. Run Make.


Actual results:

Successful compilation. However, clicking on call_function in main.cc and selecting "Jump to definition" jumps to the declaration in test.h, rather than the definition in test.cc.


Expected results:

Expect that jump to definition would jump to the definition in test.cc.

I believe this works properly on the master branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986522
You need to log in before you can comment on or make changes to this bug.