Devtools debugger: Don't list eval calls as sources

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Debugger
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Codacoder, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

Use code that uses eval, launched debugger.


Actual results:

Sources pane has recently decided to list entries like " ... > eval" per call to eval in the code. Example:
jquery.min.js > eval
jquery.min.js > eval
jquery.min.js > eval
jquery.min.js > eval
jquery.min.js > eval
jquery.min.js > eval
...
This does not scale!


Expected results:

Uh... nothing?  I fail to see how this (seemingly) endless list is helpful. If the entries could be grouped under a common heading (eg jquery.min.js [eval code]) then that might work but as it appears right now, it's ruining the UX of the sources pane.

Updated

3 years ago
Component: Untriaged → Developer Tools: Debugger
(In reply to Russ from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML,
> like Gecko) Chrome/39.0.2171.71 Safari/537.36
> 
> Steps to reproduce:
> 
> Use code that uses eval, launched debugger.
> 
> 
> Actual results:
> 
> Sources pane has recently decided to list entries like " ... > eval" per
> call to eval in the code. Example:
> jquery.min.js > eval
> jquery.min.js > eval
> jquery.min.js > eval
> jquery.min.js > eval
> jquery.min.js > eval
> jquery.min.js > eval
> ...
> This does not scale!
> 
> 
> Expected results:
> 
> Uh... nothing?  I fail to see how this (seemingly) endless list is helpful.
> If the entries could be grouped under a common heading (eg jquery.min.js
> [eval code]) then that might work but as it appears right now, it's ruining
> the UX of the sources pane.

I agree that the current approach does not scale. However, we do really want to show eval scripts in the source list, because otherwise they would not be debuggable!

In the long term, we want to convert the sources list to a (collapsable) tree, and show eval scripts as children of the sources that introduced them. That should be a lot more scalable. In the short term, we want to move all eval scripts to the bottom so they don't clutter up the sources list (bug 1111771). In addition, we are considering to hide eval scripts by default, and add a button to make them visible.

Since this bug is about removing eval scripts from the list altogether, I'm closing it as wontfix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

3 years ago
Whatever - if we end up with the eval calls "moved" or "hidden", or "grouped together" (which was my suggestion in case you missed it) I'll be happy and the bug will have been fixed :/

Updated

3 years ago
See Also: → bug 1115991
Another bug was opened about this (bug 1124106). I'm rethinking this now mainly because of debugger performance concerns.
See Also: → bug 1124106
You need to log in before you can comment on or make changes to this bug.