Closed Bug 111137 Opened 21 years ago Closed 21 years ago

Links with and without trailing '/' are not considered as the same

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 108988

People

(Reporter: dedu, Assigned: paulkchen)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

When a URL is seen, the link to it becomes visited (it changes colour on the
screen), but the link with/without '/' is not shown as having been visited.

Reproducible: Always
Steps to Reproduce:
1.(Remove history.)
2.Go to http://www.mozilla.org.
3.Click on the link 'release notes'
(http://www.mozilla.org/releases/mozilla0.9.6/) at the RIGHT, containing release
notes for 0.9.6.
4.Go back.


Actual Results:  The link at the right becomes visited, but the link in the
TOP-LEFT (pointing to http://www.mozilla.org/releases/mozilla0.9.6) is not shown
as visited.  The reason is that the two links differ by the last '/' character.

Expected Results:  Links with and without '/' at the end be considered pointing
to the same document, and show both as visited.
108988

*** This bug has been marked as a duplicate of 108988 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Blocks: 1102431
You need to log in before you can comment on or make changes to this bug.