Closed Bug 1111406 Opened 7 years ago Closed 7 years ago

word-break rule not respected on Firefox OS

Categories

(Core :: Layout: Text and Fonts, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 958887

People

(Reporter: marco, Unassigned)

Details

http://jsfiddle.net/zz9wn15j/4/

It works on Firefox on Linux, Windows and Android. It doesn't work on Firefox OS 2.0.
Component: General → Layout: Text
Product: Firefox OS → Core
The ability to set the dash-named versions of the properties on foo.style the way your fiddle does only exists starting in Gecko 35.  See bug 958887.  I'm pretty sure Firefox OS 2.0 is using an older Gecko than that.  ;)

So instead of this:

  div.style["word-break"] = "break-all";

you need to either do this:

  div.style["wordBreak"] = "break-all";

or this:

  div.style.wordBreak = "break-all";

or this:

  div.style.setProperty("word-break", "break-all");

Similar for the "word-wrap" and "white-space" properties.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 958887
Oh, thank you!

What about something like -moz-appearance? "-mozAppearance"?
  div.style.MozAppearance = value

or 

  div.style.setProperty("-moz-apperance", value)
And fwiw, I confirm that everything works as expected on current 2.2
You need to log in before you can comment on or make changes to this bug.