Status

enhancement
VERIFIED DUPLICATE of bug 18213
18 years ago
11 years ago

People

(Reporter: kaie, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I often visit index pages. All kind of pages, for example news headlines or
search engine result pages.

Very often I see on those pages multiple items that interest me. But to not lose
track, I want to stay in this page first, before I have decided which pages I
want to view and which not.

I don't like to go forward and backward, because it takes time to find the place
in the previous page where you need to continue to read. Another reason is:
Going back often means, that you have to wait again until the page is loaded.
This is slow sometimes, especially for portal pages with a lot of dynamic content.

To accomplish this I currently use the following strategy:
- I read the page
- for every interesting link, I select open in new window (middle mouse button)
- I immediately use the keyboard combination to switch back to the previous
window, to let the new window load behind, and continue reading the original page

This is little bit of a pain:
- new browser windows open slowly, and even if you don't wait until the new page
is loaded, you lose time waiting for the browser to react again
- you need a lot of system resources
- you get lost with that many open browser windows
- once you have all those pages open, you need to read them before you do
anything else, because you fear the browser could crash. If it does, you lose
the list of pages you wanted to read.

I think I have a good idea to solve this. Let's call it "Surfers Wishlist".

I suggest the behaviour of the middle mouse button chould be configurable.
Instead of opening a new window, it could "add this link to my wishlist".

This should be a silent action. Nothing visible on screen, no action, no
additional confirmations etc. Maybe just some text in the statusbar that says:
"The link to [title] has been added to your wishlist."

Whenever I want to, I can decide that I want to surf some pages from the
wishlist I have collected. It should be possible to view the wishlist as a sidebar.

This should behave like a temporary bookmark list. Every item in the wishlist
disappears from the list immediately after is was succesfully loaded. If you
surf a page, you still have to bookmark it if you want to keep it. If it is
removed from the wishlist automatically, you don't waste time by having to
remove it manually, and you make sure you see every page only once.

There should even be a shortcut that loads the next unseen page from your
wishlist, to make power surfing even faster.

Comment 1

18 years ago
New Feature Suggestion: Surfers Wishlist --> RFE: Surfers Wishlist
Sev: normal --> enhancement
Com: Browser-General --> XP Apps: GUI Features
Severity: normal → enhancement
Component: Browser-General → XP Apps: GUI Features
Summary: New Feature Suggestion: Surfers Wishlist → RFE: Surfers Wishlist

Updated

18 years ago
Summary: RFE: Surfers Wishlist → Surfers Wishlist
I think this bug would be best resolved as a duplicate of bug 56690.
Assignee: asa → blakeross
QA Contact: doronr → sairuh

Comment 3

18 years ago
Tabs can already load in the background, and 56690 is quite hard to fix cross
platform (I'd rather not even see an attempt).

As far as the request, I surf much the same way, and use tabs to open multiple
links I wish to pursue. I don't know if many users would be interested in
learning and using 'not-quite-bookmarks-but-a-wishlist!' type feature...

Perhaps you can make do with bookmarks, creatively? Open the bookmarks tab, make
a folder 'wishlist', and drag links there when you want to pursue them? Not
quite as easy, but your implementation sounds a bit too specialized.

I just go for the "use background tabs and trust Mozilla not to crash" method,
which occasionally backfires, but is quite tolerable.

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 18213 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.