Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: norguet_web, Assigned: dcone)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Bug 67681 also reproducable with the chess board on this page :
http://www.very-best.de/PC.htm?tour=test

The Mozilla 0.9.6 (and most below) print under PC Windows 2000 (also PC Linux
RedHat 7.1) leaves the a3 and a5
empty squares white, printing on a BW laser printer in grayscale and color mode.
All the black squares with a piece on it are printed white too.

Everything works fine when printing with IE 5.0 and Netscape 4.7x

[Note : we init severity with 'blocker' as it prevents us from using Mozilla and
the bug report guidelines do not specify much more value scaling, of course it
affects not-every user]
(Reporter)

Comment 1

17 years ago
update : the printing under IE leaves all the chess board squares white, which
is not desirable either

Comment 2

17 years ago
same problem here but I wouldn't call it a blocker
I have
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011120

Comment 3

17 years ago
Build ID: 2001 11 20 03. Windows 2000.

I can confirm: a3 and a5 are incorrectly white, as are populated black squares,
when printed on my HP LaserJet 4050/PCL6. Print Preview seems ok though.

Reporter: Please click the link "Severity" to the left of the ComboBox and read...

  Blocker: Blocks development and/or testing work

Maybe "Normal" would be appropriate for this one?

Comment 4

17 years ago
Downgrading to major for now.
Severity: blocker → major
There seems to be a (transparent?) image over the a column.  This is likely the
perennial bug about transparent things not printing quite right... (bug 12037)
(at least bug 12037 is what I see on this page -- lots of black squares...)

Comment 6

17 years ago
I see two problems here:

1) the blank white squares in the chessboard. is it possible this
    is related to the bug 111953 (table background printing turned off)

2) the chessboard is shifted to the left in the output. it should be
on the right.

Comment 7

17 years ago
Normal severity. This is not a major problem.

As Boris Zbarsky said, this was probably a dupe of bug 12037.

Worksforme with File | Page Setup | Print Background colors and images checked,
Build ID: 2002041803 (0.9.9+) trunk Windows 98.

This bug concerns the squares a3 and a5 on the chessboard printing white. With
the above configuration, they print in the same grayscale shade as the other
"black" squares.

There also seems to be a problem with the layout of the page. That should be
filed in a separate bug, though.

Another possible separate bug is that the white pieces on black spaces are
printed transparently, but not rendered on screen transparently.

Reporter, could you try this problem again on a new build? You can download an
updated nightly build from 

ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe

Close Mozilla and run that program. Running a nightly build can be a little
risky. Please back up your Mozilla data first, including your bookmarks. If
you'd like, you could wait for 1.0, the next milestone release. That will
probably be released within a short period.
Severity: major → normal
confirming. using Mozilla 1.0 RC1, Windows 2000 SP2
Page Setup | Print Background colors and images checked

squares a3 and a5 are white on print (HP Laserjet 5).
print preview display them correct (gray).

additionally, black squares with chess piece on it are 
printed white too (displayed gray on print preview).
I'm seeing this bug with solaris trunk nightly 2002-04-23-22 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

17 years ago
The Chess board prints fine for me.. except the "a" column.  It looks offset or 
something.  The chess pieces are transparent.. my guess... so there 
background..or the tranparent part it white.. which is as it should be.  We do 
not composite ourselves... and most printers do not support tranparency bit 
blits.. so we make that transparent part white by design. The print backgrounds 
check box in the print setup must be checked to see the board. The offset of the 
board is a layout issue.  I wont close this right now until I have heard more 
discussion.. but if this bug is about the white where the chess pieces are.. 
thats by design.  Mac and Linux still have the transparency with black problem.. 
and there are bugs open for that.
using Mozilla 1.0 RC1, SuSE Linux 8.0
Page Setup | Print Background colors and images checked

squares a3,a4,a5,a6 are white, b2 - h6 are gray and light gray on print.
other squares with chess pieces are white.

looking at the html-source shows that a3-a6 also have a transparent
image: 
<td bgcolor="#FFCC66"><img src="/img/i.gif" border=0  width=32 height=32></td>
b2-h6 dont have an image. 

if transparent part of images are printed white by design, its not a bug. 
(Reporter)

Comment 12

17 years ago
Reacting on
 Additional Comment #7 From Andrew Hagen 2002-04-18 08:57,

I am the reporter and I tried 2002-05-10 build to see the problem status, which 
I consider as 'fixed' now.

I also agree with the 'separate bugs' remarks.

Thank you all !
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
verified per comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.