View of Message source should keep the character coding

RESOLVED FIXED in mozilla1.2alpha

Status

RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: lizal, Assigned: bugzilla)

Tracking

({intl, polish})

Trunk
mozilla1.2alpha
x86
Windows NT
intl, polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
The newly implemented View of Message source (View/essage soUrce) should keep
the character coding which was set for the Mail, i.e., the setting of
View/CharaCter coding, (instead of using the Western coding by default? In my
case, it uses Western instead of the selected Central european ISO.) The proper
coding is not used even if the mail header contains section
Content-Type: text/plain;
	charset="iso-8859-2"

Updated

18 years ago
Keywords: intl

Comment 1

18 years ago
Confirming on 2001112003, Win98, for plaint text and html messages written in
ISO8859-7 (8 bit text in body, correct mime information). Marking as NEW, adding
intl keyword.

Comment 2

18 years ago
Confirming on 2001112003 (trunk), Win98, on plain text and html messages with 8
bit body and correct mime info (ISO-8859-7). Tried on new profile, same results.
Marking as NEW, adding intl keyword.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
Created attachment 58737 [details]
Message source of a testcase

Source of a message that isn't displayed correctly on View Message Source.

Updated

18 years ago
QA Contact: esther → marina

Updated

18 years ago
QA Contact: marina → ji

Comment 4

18 years ago
i am seeing this with 2001-11-26-03 build

Comment 5

17 years ago
reassigning to ducarroz.
Assignee: sspitzer → ducarroz

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2

Comment 6

17 years ago
Using Mozilla build 2002040814

I think my problem belongs to 111164 bug:

Original message:
A questão é que, em casos de NAT, o StoneGate permite alterar o endereço IP
de origem, quando este faça parte do _payload_ do pacote em alguns
protocolos, para o endereço de NAT. O cliente pretende saber se o FP1 também
tem essa funcionalidade.

With View Message Source:

A quest=E3o =E9 que, em casos de NAT, o StoneGate permite alterar o =
endere=E7o IP
de origem, quando este fa=E7a parte do _payload_ do pacote em alguns
protocolos, para o endere=E7o de NAT. O cliente pretende saber se o FP1 =
tamb=E9m
tem essa funcionalidade.

Comment 7

17 years ago
*** Bug 126120 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
The same problem also occurs when opening an attachment that is displayed
inline, e.g. a .pdf file. After viewing such an attachment, the display of
special characters (German Umlauts) is messed up.

Comment 9

17 years ago
Created attachment 83677 [details]
Display of German Umlauts before opening pdf attachment (correct)

Comment 10

17 years ago
Created attachment 83680 [details]
Display of Germn Umlauts after opening pdf attachment

Comment 11

17 years ago
QA contact to marina. Thanks.
QA Contact: ji → marina
Created attachment 99046 [details] [diff] [review]
Proposed patch

I've included some cleanup in this patch:
I used try/catch because getService doesn't return null, it throws exceptions.
I removed the "?header=src" which is no longer necessary.

Updated

17 years ago
Depends on: 125723
I don't know who's best to review this so CCing likely suspects.
Keywords: patch, polish, review
Comment on attachment 99046 [details] [diff] [review]
Proposed patch

r/sr=bzbarsky, but please use the When In Rome rule on the whitespace here..
unless the file already has all sorts of mixed whitespace styles, of course.
Attachment #99046 - Flags: superreview+
Created attachment 99256 [details] [diff] [review]
Fixed whitespace

Comment 16

17 years ago
Comment on attachment 99256 [details] [diff] [review]
Fixed whitespace

r=nhotta
Attachment #99256 - Flags: review+
checked in, marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.