bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Feature Proposal: Add Time/Battery/Signal/BT status icons to Call Screen

RESOLVED DUPLICATE of bug 1103283

Status

Firefox OS
Gaia::Dialer
--
enhancement
RESOLVED DUPLICATE of bug 1103283
4 years ago
4 years ago

People

(Reporter: Brett Edmond Carlock, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8536672 [details]
Current Call Screen (Blank status bar)

Currently (Flame v2.2 nightly), the Call Screen does not draw any of the Status Bar icons/items at all.

I understand this is probably designed to present a clean view to the user, but there are 5 things the user might likely check when in a call, even on the call screen:
1) Time [Always]
2) Battery [Always]
3) Cellular Radio Signal [Always]
4) BlueTooth Status (only if connected/in-use)
5) Wired Headphone/Headset Status (only if connected/in-use)

I think these five items should be able to draw on the Status bar while on the Call Screen, even if the other Status Bar icons are not allowed to draw.

To check any of those things (all very important when making a call), I have to dismiss the Call Screen, go to the desktop, then invoke the Call Screen again.
(Reporter)

Comment 1

4 years ago
Created attachment 8536680 [details]
Mockup of Improved Call Screen Status Bar

In this view, you can see that the time, battery, and cellular radio strength are viewable on the Call Screen Status bar. If I was using a BlueTooth headset or wired headset, then those icons would also draw here so the user can be kept aware of the full status of their call.
(Reporter)

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Updated

4 years ago
Flags: needinfo?(cawang)
This is actually a regression, the statusbar should have always been there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1103283
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(cawang)
You need to log in before you can comment on or make changes to this bug.