entry field causes browser to hang

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: T. Engelhardt, Assigned: Alexandru Savulov)

Tracking

({hang})

Trunk
mozilla1.1alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

I use Mozilla 0.96 on a W2k-system. The problem occurs at the www.comdirekt.de
web-site. There's an entry-field on the left side with the name "Kursabfrage".
The first time I enter the name of a share that I want to see, everything works
fine. But after several entries sooner or later mozilla uses 99% of my systems
ressources and hangs, but doesn't crash. I had the same problem with the 0.95
version.

Reproducible: Always
Steps to Reproduce:
1. Enter a share name, e.g. Transmeta and hit enter.
2. Enter a second one, e.g. Brokat and hit enter.
.... repeat till system locks up - usually after 2 or 3 times.

Actual Results:  Mozilla uses 99% of my system's resources, but it's impossible
to close the program.

Comment 1

16 years ago
Build ID: 2001 11 20 03. Windows 2000.

Confirm hang and CPU sucking (already at second entry).

Suggest keyword "hang" (I'm too weak to set it myself).

Updated

16 years ago
Keywords: hang

Comment 2

16 years ago
Confirming this bug on Mozilla 0.9.6+
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011121. I was able to
kill Mozilla by using Ctrl-Alt-Del "end task" twice.

It did take me about 5 stocks to get it to hang. If this turns out to be a
memory problem, I have 128MB in my system. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
->form submission?
Assignee: asa → alexsavulov
Component: Browser-General → Form Submission
QA Contact: doronr → vladimire
(Assignee)

Comment 4

16 years ago
setting milestone.


tested with build 2002010703, todays pull, NS6.2 an win2000 and WFM.
(memory consumption is reasonable 24M/15M VM)

reporter and all:

It would be nice if you could find the reason of his hang, provide a reduced
testcase and see if it is relly related to form submission.
BTW: are you using the german language pak with mozilla?
Target Milestone: --- → mozilla1.1

Comment 5

16 years ago
After trying 10 fields I could not reproduce either (Linux 2002011808).  Is this
still happening?

Comment 6

16 years ago
works for me on 2002-01-25-03-trunk windows 2000, reslving 
toenit00@fht-esslingen.de (T. Engelhardt), please reopen if you still see it
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
verifying...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.