Incorrect Version Info in Windows Install (Control Panel - Add/Remove)

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: lkolesza, Assigned: curt)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6+) Gecko/20011120
BuildID:    2001112003

Help about reports version as 0.9.6+
Add/Remove shows program as "Mozilla (0.9.5+)"

Reproducible: Always
Steps to Reproduce:
1. Install daily build
2. Open Add/Remove Programs

Actual Results:  Shows in list as "Mozilla (0.9.5+)"

Expected Results:  Shows in list as "Mozilla (0.9.6+)"

Comment 1

17 years ago
In linux in the window title I have"  "page title - Mozilla 0.9.5",
although I have mozilla 0.9.6

Updated

17 years ago
Target Milestone: --- → M1

Updated

17 years ago
Target Milestone: M1 → Future

Comment 2

17 years ago
*** Bug 113852 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: bugzilla → gbush
*** Bug 114393 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
This is a duplicate from bug 114208 which seems to be fixed. I haven't tried it yet.
Don't know how to mark this as duplicate.
(Reporter)

Comment 5

17 years ago
This is not a duplicate of 114208.  That bug refers to the useragent version
reported to web servers.  This bug refers to the version reported in the Windows
add/remove programs tool.

 

Comment 6

17 years ago
Could we change the summary to make this bug more clear?

OLD: 
Inconsistent version information in windows install

NEW: 
Incorrect Version Information in Windows Install (Control Panel - Add/Remove)
(Reporter)

Updated

17 years ago
Summary: Inconsistent version information in windows install → Incorrect Version Info in Windows Install (Control Panel - Add/Remove)
(Reporter)

Comment 7

17 years ago
This bug has been rendered obsolete by the branch for 0.9.7.
The trunk builds now correctly report themselves as 0.9.7+ in Add/Remove programs.

Comment 8

17 years ago
I still see 0.9.5+ on buid "mozilla-win32-installer-sea 2001-12-17.exe"

I just install over older versions, but this wrong version reporting (0.9.5+)
shouldn't be happening anyhow.
(Reporter)

Comment 9

17 years ago
Sorry I should have been more specific.  Build 2001121803 reports itself as
0.9.7+ in Add/Remove programs.
I'm pretty sure Curt fixed this
Assignee: syd → curt
Target Milestone: Future → ---
(Assignee)

Comment 11

17 years ago
This has been fixed as part of the 0.9.7 branching process.  0.9.7+ is what it
should be (and is).

Status: NEW → ASSIGNED
(Assignee)

Comment 12

17 years ago
Ditto the last comment so it will let me mark it fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
verified on mozilla build 200121909 and trunk 2001121803
Status: RESOLVED → VERIFIED

Comment 14

17 years ago
using: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011219

Now I get:

"Help About":  0.9.6+ 

Control Panel: 0.9.7+

Now what's wrong?

Comment 15

17 years ago
Should I file another bug, or reopen this one to fix the help about issue?
(Assignee)

Comment 16

17 years ago
Lets open another bug.  I don't think that the help/about has anything to do
with the installer.  CC myself and granrose.
The about: screen version comes from the user agent -- apparently that was not
updated for the trunk, and that would be a different bug.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.