e10s profiler breaks b2g profiling

RESOLVED FIXED in mozilla37

Status

()

Core
Gecko Profiler
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

unspecified
mozilla37
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8536826 [details] [diff] [review]
patch

For now lets leave b2g profiling alone.
Attachment #8536826 - Flags: review?(mconley)
Comment on attachment 8536826 [details] [diff] [review]
patch

Review of attachment 8536826 [details] [diff] [review]:
-----------------------------------------------------------------

::: tools/profiler/platform.h
@@ +364,5 @@
>    static bool CanNotifyObservers() {
> +#ifdef MOZ_WIDGET_GONK
> +    // We use profile.sh on b2g to manually select threads and options per process.
> +    return false;
> +#elif defined(SPS_OS_android) && !defined(MOZ_WIDGET_GONK)

The !defined(MOZ_WIDGET_GONK) is redunant if we're elif'ing that ifdef MOZ_WIDGET_GONK.
Attachment #8536826 - Flags: review?(mconley) → review+
(Reporter)

Comment 2

4 years ago
It's true, but I like keeping stuff like that because it means that even if we remove my patch we still don't want GONK to fall into that path.
(Reporter)

Comment 4

4 years ago
Waiting on inbound.
Flags: needinfo?(bgirard)
https://hg.mozilla.org/mozilla-central/rev/73fa6e65763d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1112442
You need to log in before you can comment on or make changes to this bug.