m.yelp.com photo page doesn't resize correctly when switching back from landscape

RESOLVED DUPLICATE of bug 1210807

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1210807
3 years ago
2 years ago

People

(Reporter: Simon Boudrias, Unassigned)

Tracking

33 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2250.0 Safari/537.36

Steps to reproduce:

1. Go to mobile yelp photo page: http://m.yelp.com/biz_photos/ame-san-francisco
2. Turn the phone to go on landscape
3. Swipe to change photo once
4. Turn back the phone in portrait


Actual results:

The page doesn't resize correctly, and then a second in, actually zoom to fill the space. At this point, the header width of the webpage is bigger than the viewport.

I checked to make sure this wasn't a bug caused by Yelp's JavaScript. Apparently there's no width control, only height check to make the page fill the available vertical space.


Expected results:

When turning the phone back in portrait mode, the page should fit the viewport again without zooming.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210807
You need to log in before you can comment on or make changes to this bug.