Closed Bug 1111907 Opened 7 years ago Closed 6 years ago

[FFOS2.0][Woodduck][BT]Could not unpaired automatically after finish receive file

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1119642
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: sync-1, Unassigned, NeedInfo)

References

Details

Attachments

(2 files)

DEFECT DESCRIPTION:
 Could not unpaired automatically after finish receive file. 
 
  REPRODUCING PROCEDURES:
 1.Make sure MS is not paired with the remote BT device before;
 
 2.send a file from remote device to MS via BT;
 
 3.after finish receive file, check the BT setting screen;
 
 3.the remote device still in paired list--KO.
 
 
  EXPECTED BEHAVIOUR:
 >temporary paired connection will unpaired after finish receive file.
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: Woodduck
Flags: needinfo?(fan.luo)
(In reply to sync-1 from comment #0)
> DEFECT DESCRIPTION:
>  Could not unpaired automatically after finish receive file. 
>  
>   REPRODUCING PROCEDURES:
>  1.Make sure MS is not paired with the remote BT device before;
>  
>  2.send a file from remote device to MS via BT;
>  
>  3.after finish receive file, check the BT setting screen;
>  
>  3.the remote device still in paired list--KO.
>  
>  
>   EXPECTED BEHAVIOUR:
>  >temporary paired connection will unpaired after finish receive file.

I think this depends on behavior of stack itself. Settings actually call get paired list and refresh the latest paired device. We need partner provide analysis for this issue from stack side.
Attached video video.MP4
This issue could be repro on Woodduck 2.0M and Flame 2.0/2.1/2.2
I have uploaded video and logcat of Flame 2.1
See attachment: video.MP4 and logcat_v2.1_1837.txt
Found time: 18:37
Rate: 100%

Woodduck 2.0 build:
Gaia-Rev        09097552f236b1482ce469b4c7d92d80d0706f83
Gecko-Rev       aa9ece9c8a749095834e7a980166543d985a3af5
Build-ID        20141217050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1418763978
FW-Date         Wed Dec 17 05:06:44 CST 2014

Flame 2.0 build:
Gaia-Rev        f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/12aea1649f5a
Build-ID        20141216000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141216.031730
FW-Date         Tue Dec 16 03:17:40 EST 2014
Bootloader      L1TC00011880

Flame 2.1 build:
Gaia-Rev        79286eafe67707d1330966c1b1413b2d0de595d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/222a62b532db
Build-ID        20141216001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141216.034704
FW-Date         Tue Dec 16 03:47:14 EST 2014
Bootloader      L1TC00011880

Flame 2.2 build:
Gaia-Rev        af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a3030140d5df
Build-ID        20141216040205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141216.075002
FW-Date         Tue Dec 16 07:50:14 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo) → needinfo?(jocheng)
Attached file logcat_v2.1_1837.txt
Hi Jason,
we need MTK to check the behavior of stack for temporary paired connection. Thanks!
Flags: needinfo?(jocheng) → needinfo?(chien-hao.li)
Hi Liang,
Please check it. Thanks.
Flags: needinfo?(chien-hao.li) → needinfo?(liang.cheng)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119642
hi
 
 is there any news about this bug?
You need to log in before you can comment on or make changes to this bug.