Missing entry point ??_7nsPrivateSharableString@@6B@

VERIFIED DUPLICATE of bug 113180

Status

VERIFIED DUPLICATE of bug 113180
17 years ago
14 years ago

People

(Reporter: tom, Assigned: rdayal)

Tracking

Trunk
mozilla0.9.8
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
After upgrading from mozilla 0.9.5 to 0.9.6 (same installation directory)
mozilla starts with two messageboxes that entry points in the xpcom.dll
cannot be found. After dimissing these boxes the browser starts up, but you'll
get these messages again, when you try to open "Help / About Plug-ins", for
instance.

The missing entry points are:
"?SizeOf@nsString@@UBEXPAVnsISizeOfHandler@@PAI@Z"
"??_7nsPrivateSharableString@@6B@"

I installed mozilla 0.9.6 from the "mozilla-win32-0.9.6-installer.exe".

I hope that helps...

Regards
Thomas

Comment 1

17 years ago
-> Installer
Assignee: dougt → syd
Component: XPCOM → Installer
QA Contact: scc → bugzilla
Basically a dupe, but a different entry point so might indicate another obsolete
.dll to add to the list.
Assignee: syd → curt
Summary: Missing DLL entry points in xpcom.dll → Missing entry points ?SizeOf@nsString@@UBEXPAVnsISizeOfHandler@@PAI@Z

Comment 3

17 years ago
sounds like the installer should clean up its installation directory....
Status: UNCONFIRMED → NEW
Ever confirmed: true
The installer will happily clean up when people tell us they've obsoleted
something, but they never do until we start seeing bugs like this. The install
team has bugs and features of its own, we're not your mother.

As for wiping *everything* out we used to do that, and still do on Linux and
Mac. See other bugs for all the complaints about doing it that way.

Comment 5

17 years ago
I've taken two screenshots of the two message boxes that pop up explaining the
entry points.
They're available for viewing at:
http://www.gigacluster.net/~pwhite/mozilla/
as the two .png images.
(Reporter)

Comment 6

17 years ago
May be I made something wrong first time, but today I installed mozilla 0.9.6
again (after uninstalling it, re-installing 0.9.5 and now upgrading to 0.9.6 once
again) and I cannot reproduce that problem since the last re-install.
The difference is, that first I didn't install the "Privacy&Security" component,
now I did and it seems to work fine...

There's also Bug 111568 (http://bugzilla.mozilla.org/show_bug.cgi?id=111568) which
seems to be solved or "worked around" by installing the "Privacy&Security"
component.

Updated

17 years ago
QA Contact: bugzilla → gbush
I'm getting the nsPrivateSharableString one myself. Unlike the component
registration bugs which happen only once after installation (or if you go to
about:plugins) this is happening to me on every start.

I've tracked it down to my daily build trying to use the Netscape 6.2 copy of
msgMapi.dll -- must be looking in the windows registry for it or something.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7

Comment 8

17 years ago
So is the solution for the same as for the Component registry bugs, i.e. have
the installer clean up msgMapi.dll when upgrading.  Or do I need to look around
for a registry setting or something else that also needs cleaned up?
No -- that's why this one scares me. We can't reach into some other installation
and delete things, that'll screw up that other version and the fact that someone
is keeping both (by changing the default so it installs into a new directory)
indicates they might be unhappy if we did that.

Maybe this should be bounced over to the mail folks to find out why current
builds are trying to load a .dll out of the Netscape 6.2 directory.
Summary: Missing entry points ?SizeOf@nsString@@UBEXPAVnsISizeOfHandler@@PAI@Z → Missing entry point ??_7nsPrivateSharableString@@6B@

Comment 10

17 years ago
Scott, could you look into this one.  Now that I've got it straight what Dan was
trying to tell me it looks like something in mail may be looking in the wrong
place for this dll? so this likely is not an installer problem.
Assignee: curt → mscott
Status: ASSIGNED → NEW

Comment 11

17 years ago
sounds like you are saying this is a mapi dll that's trying to get loaded? Over
to the mapi guru Rajiv. 
Assignee: mscott → rdayal
(Assignee)

Comment 12

17 years ago
This must be happening because we have the MAPI implementation only in 0.94
branch (used for N6.2) and has not yet landed on the trunk. The mapi dll
'msgMapi.dll' is explicitly loaded by a LoadLibrary call from
nsNativeAppSupportWin which is part of the trunk though (made for the reasons of
a plan decided for enabling a separate add on release of MAPI to corporate
customers). Thus when this call is made since msgMapi.dll does not exist in
releases after 0.94/N6.2 the msgMapi.dll tries to get loaded from the N6.2 dir
which would be in PATH.

This however is being fixed as part of the bug 106137 and will thus resolve this
problem too. There would be no explicit call for msgMapi.dll from
nsNativeAppSupport. Making this bug dependent on bug 106137.
Depends on: 106137

Comment 13

17 years ago
106137 is scheduled for 0.9.8, so since this depends on it, moving this one to 0.9.8
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 14

17 years ago
There is a patch (id=56177) on bug 106137 which removes the code from xpfe for
MAPI support which has r and sr. If required we can checkin this patch which
will remove the LoadLibrary call for msgMapi.dll. And thus this warning messages
boxes will not be seen. 

Also checking in this patch should be safe since MAPI support is not yet on the
trunk and this patch only removes code related to only MAPI. I also did some
testing yesterday and today to replicate this problem and then verify that
removing the LoadLibrary call or applying this patch (id=56177, which
has-super-review) on bug # 106137 resolves this problem.
At the same time it should be noted that this would happen only if Netscape 6.2
/ Mozilla 0.94 is also installed / co-exist on the system and also only if the
N6.2 /M0.94 installation dir is in PATH.

6.2 is not on my path. This message comes up when I use the desktop shortcut
(which does not contain the 6.2 path) but not if I start the browser from a
command prompt.
(Assignee)

Comment 16

17 years ago
The patch (id=56117) in bug # 106137 has been checked in yesterday which removes
the call to load msgMapi.dll. Can you see with today's build if you still see
the problem ?

Comment 17

17 years ago
marking dup

*** This bug has been marked as a duplicate of 113180 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 18

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.