when pulling up the task manager in horizontal orientation it opens it verticaly

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Jamie_, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141215134203

Steps to reproduce:

you have multilpe apps running and you are using one in a horizontal orientation say you are typing something and you go to switch to another app via task manager.


Actual results:

it will automaticly snap as if you are holding it verricaly whether or not you are switching to another app this is able to be used horizontaly


Expected results:

it should remain in a horizontal orientation untill you select to use an app that can not be used horizontaly
:djabber, :sfoster
This bug has been filed by a new contributor to FirefoxOS who was doing a testing task in One and Done:
https://oneanddone.mozilla.org/tasks/78/

The UX implementation calls for the Task Switcher to work only in the portrait mode. Is this going to change?
Status: UNCONFIRMED → NEW
Component: General → Gaia::System::Window Mgmt
Ever confirmed: true
Flags: needinfo?(fdjabri)
This is what is specified in the current UX specs but will almost certainly be out of scope for the 2.2 release.
Flags: needinfo?(fdjabri)
We're tracking these orientation/task manager issues in bug 1111795, this might be a dupe of one of the bugs under it. As of today in master/nightly the task-manager can open in landscape, but it has several bugs. I would love to get these fixed for 2.2, but it is most important that it is consistent and stable, so I'm not sure yet if it will make the cut.
Blocks: 1111795
For 2.2, we will lock orientation for the task switcher so that it is always portrait-primary. That is, this bug is expected behavior. Having a landscape-capable task manager is definately on UX' radar. When we start planning 3.0 we'll revisit the issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.