delete and return ought to go back and forward

VERIFIED WONTFIX

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED WONTFIX
17 years ago
15 years ago

People

(Reporter: strobe anarkhos, Assigned: Brade)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011120
BuildID:    2001112005

delete and return ought to go back and forward

It's a common shortcut

Reproducible: Always
Steps to Reproduce:
too obvious to mention

Actual Results:  too obvious to mention

Expected Results:  too obvious to mention
this has been partially implemented [backspace going back a page] on win32 in
bug 108816.

should this be marked a dup of bug 33684?
Assignee: pchen → aaronl
Component: XP Apps → Keyboard Navigation

Comment 2

17 years ago
I disagree, I think this bug should be invalid. Command-[ and Command-] are perfectly 
reasonable keyboard equivalents for these menu items. It's what command keys are for. 
Delete and return are not obvious keyboard shortcuts at all. It's a bad idea; I can think of 
no situation in which I would want these keys to do such a thing.

If you must have them, then they should be _Command_-return and _Command_-delete, 
but I'd still say just forget about this.

I do see that the Command-[/] keyboard shortcuts aren't displayed in the Go menu...I 
wonder if a bug is already filed on that.
(Reporter)

Comment 3

17 years ago
Most browsers support these shortcuts, and I find them a lot easier to use than
a command modifier. Only takes one jab at the keyboard.I especially find them
useful in Explorer where I only have the "Address Bar".

Nobody said we should remove the command modifiers, and nobody is going to
inadvertantly hit the delete key. Don't be so anal, next you'll complain that
all Cocoa text fields support EMACS shortcuts. 

Updated

17 years ago
Severity: minor → enhancement

Comment 4

17 years ago
First of all, the bug summary and description don't indicate whether you mean
back/forward by page or in the session history.

Second of all, in what browser does return go forward?

Hitting enter/return on a link jumps to it in most browsers, but we already do that.

(Reporter)

Comment 5

17 years ago
I mainly use Internet Explorer for OS X which exibits the behavior I'm talking
about. delete/return are analogous to hitting the backward/forward buttons or
command-left/command-right.

Comment 6

17 years ago
Actually, return just looks like it's going forward.

What it's really doing is moving to the page pointed by the link you're focused on.

In any case, this isn't behavior desired in Mozilla.

*** This bug has been marked as a duplicate of 108816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Not quite a dup. The other bug was filed against windows, where this
functionality is expected behaviour. 

This is a Mac bug. I'm not aware of the policy on Mac, so I'll leave for a Mac
person to either give the go ahead for implementation, or INVALIDate
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 8

17 years ago
-> brade, mac
Assignee: aaronl → brade
(Assignee)

Comment 9

17 years ago
opinions?
no, we shouldn't do this. what if the user gets confused and hits backspace
while they think the focus is in the url bar...the page goes back and they lose
what they were trying to do.

forward and back are expensive operations and can cause data loss (ever try
going back on some secure pages? the server freaks out and kicks you back to the
beginning). a simple keystroke should NOT cause something so drastic to happen.

i say WONTFIX.

Comment 11

17 years ago
I agree with pinkerton - WONTFIX
(Assignee)

Comment 12

17 years ago
hurray!  consensus!  WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX
well then!
Status: RESOLVED → VERIFIED

Comment 14

15 years ago
So, um, why did we implement this in Camino? It was a hot feedback item, iirc.
because we changed our minds?
tested with a 2003.05.14 camino build: delete goes back, shift-delete goes
forward. (return should never go fwd, since return/enter are reserved for
activating the focused item in a page, if any.)
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---
dang it, my brain didn't register that this bug is for mozilla. back to wontfix
for moz/nscp.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WONTFIX
ahem.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.