@import of stylesheet fails

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Michael Cramer, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011120
BuildID:    2001112021

Using the @import directive within a <style> block does nothing. The @import
directive worked properly with builds up to and including 2001111821. Builds
from 11/19, 11/20, and 11/21 all show the same, incorrect behavior.

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.webkist.com/
2. The style is split into to pieces -- positioning and non positioning style.
The positioning style is loaded via an @import directive.
3. The positioning style does not work, while the non-positioning style (which
is hardcoded into the page) does.
4. Visit http://www.webkist.com/index2.html to see the page working properly,
with all style hardcoded.

Actual Results:  Incorrect positioning of content on the page.

Expected Results:  Correct layout, as seen on http://www.webkist.com/index2.html.

I didn't test every build since 11/18, but it seems that the bug was introduced
somewhere during 11/19 because the last linux build on that day shows the
incorrect behavior.
The page uses strict mode and serves the stylesheet as text/html.  We now ignore
stylesheets served with a content-type other than text/css in strict mode (as of
Nov 19, as you noted).

Please fix your web server to serve the stylesheet with the correct content
type.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
QA Contact: stummala → ian
Resolution: --- → INVALID

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.