If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IonBuilder: Inline SIMD calls.

RESOLVED FIXED

Status

()

Core
JavaScript Engine: JIT
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: nbp, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Use macros for generating code for most/all of the primitive SIMD natives.
The MIR code should be annotated with the right TypePolicy for unboxing the
inputs, and the output should be boxed after each SIMD instruction.
(Reporter)

Updated

3 years ago
Depends on: 1112156
(Reporter)

Updated

3 years ago
Blocks: 1112158
(Reporter)

Updated

3 years ago
Depends on: 1113179
(Reporter)

Updated

3 years ago
Depends on: 1068028
(Reporter)

Updated

3 years ago
Depends on: 1118344
(Reporter)

Updated

3 years ago
Depends on: 1127929
(Reporter)

Updated

3 years ago
Depends on: 1127932

Updated

3 years ago
Depends on: 1129148
Duplicate of this bug: 943769
Depends on: 1134638
Depends on: 1135038
Depends on: 1135039
Depends on: 1135040
Depends on: 1135042
Depends on: 1136189
Depends on: 1146363
Depends on: 1084319
I think this is done.

We insert explicit MSimdUnbox / MSimdBox instructions when inlining instead of relying on the TypePolicy, but the result is the same.
Flags: needinfo?(nicolas.b.pierron)
(Reporter)

Comment 3

a year ago
Sweet, first time I have the opportunity to close a meta bug as fixed \o/.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nicolas.b.pierron)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.