[Camera] When taking a photo, there is no flash even when the flash is on/automatic

RESOLVED DUPLICATE of bug 1111752

Status

RESOLVED DUPLICATE of bug 1111752
4 years ago
4 years ago

People

(Reporter: psiphantong, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8537295 [details]
logcat.txt

Description:
When taking a photo, there is no flash even when the flash is on/automatic 


Repro Steps:
1) Update a Flame to 20141216040205
2) Go to camera
3) Take a photo in the dark


Actual:
No flash

Expected:
Flash displays


Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141216040205
Gaia: af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko: a3030140d5df
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%,
See attached:logcat,video clip:https://www.youtube.com/watch?v=ApOEa8kyM5c
(Reporter)

Comment 1

4 years ago
This issue does not reproduce on the Flame 2.1 and the Flame 2.0, the flash displays when taking a photo

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141216001202
Gaia: 79286eafe67707d1330966c1b1413b2d0de595d9
Gecko: 222a62b532db
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141212000203
Gaia: f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko: 32f9fae79b89
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Camera flash functionality not working. Regression. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141212180051
Gaia: 5a59bd4dddff0ab5b86c93c9dccd7cbfd25ee07f
Gecko: 120465dd70d2
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141212184346
Gaia: 5a59bd4dddff0ab5b86c93c9dccd7cbfd25ee07f
Gecko: cf975e8c033d
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=120465dd70d2&tochange=cf975e8c033d
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage]
Flags: needinfo?(jmitchell)
Broken by either the patch to  Bug 1052821 or  Bug 1104055 - can you take a look Mike?
QA Whiteboard: [QAnalyst-Triage] → [QAnalyst-Triage+]
Flags: needinfo?(mhabicher)
QA Contact: pcheng
Bug 1111752 should fix this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mhabicher)
Resolution: --- → DUPLICATE
Duplicate of bug: 1111752

Updated

4 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.