Implement ::shadow pseudo-element for access into shadow root

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
3 years ago
a year ago

People

(Reporter: Luis Garcia, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
(Reporter)

Updated

3 years ago
Blocks: 811542
Version: 36 Branch → unspecified
Keywords: dev-doc-needed
This is one of the parts of the draft that we may not end up doing as-is, depending on what else happens in the shadow DOM styling story.

Comment 2

3 years ago
Link to specification for reference: http://dev.w3.org/csswg/css-scoping-1/#shadow-pseudoelement
(Reporter)

Updated

3 years ago

Comment 3

3 years ago
related issue: Implement >>> Selecting Through Shadows Selector for access into shadow root - https://bugzilla.mozilla.org/show_bug.cgi?id=1117572
I think this might belong in DOM :: CSS Object Model - please correct if I am mistaken.
Component: DOM → DOM: CSS Object Model
If it's for implementing the pseudo-element in selectors, CSS Parsing and Computation is better.
Component: DOM: CSS Object Model → CSS Parsing and Computation
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
To clarify, "CSS Parsing and Computation" is about parsing CSS and figuring out the values of CSS properties.  "DOM: CSS Object model" is about scriptable reflections of CSS objects (rules, declarations, and so forth).  If no JS is involved, it's not a "DOM: CSS Object model" issue.
(Reporter)

Comment 7

3 years ago
It is also should be implemented in JS (such 'querySelector' and perhaps 'closest').
Those automatically pick up changes to selector matching, generally.  But for the pseudo-element case they may need changes, yes, since right now those never match pseudo-element stuff.  That would probably be a separate bug, and putting that one in CSSOM may make sense.
See Also: → bug 1117572
Looks like the shadow-piercing descendant combinator >>> is the replacement for the ::shadow pseudo-element.[1] Boris, should this bug be marked as WONTFIX in favor of bug 1117572 or is it still too early?

Sebastian

[1] https://drafts.csswg.org/css-scoping-1/#selectordef-shadow-piercing-descendant-combinator
Flags: needinfo?(bzbarsky)

Comment 10

a year ago
As-is this is INVALID since the standard changed. It's also unclear whether we want to implement >>> at this time (I'll comment on the other bug).
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Regarding comment 10 I remove the ni for Boris.

Sebastian
Flags: needinfo?(bzbarsky)
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.