PointerLock locks outside browser on retina screen in non-e10s mode

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: mrspeaker, Assigned: smichaud)

Tracking

(Blocks 1 bug, {regression})

37 Branch
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, firefox35 unaffected, firefox36 unaffected, firefox37+ fixed, firefox38+ fixed)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141216030203

Steps to reproduce:

Opened the PointerLock MDN demo: http://mdn.github.io/pointer-lock-demo/ and agreed to pointer lock request


Actual results:

On the retina screen (Mac) the pointer is instantly pushed out of the browser window area to the bottom left edge of the desktop. 

If you try and hover your mouse back over the browser, it's pushed away again - not allowing you to interact with the browser window at all. 

You need to hit escape to cancel pointerlock and resume browsing. This only happens on the retina screen - attaching a secondary non-retina screen and running the demo there works as expected.


Expected results:

Pointer lock should be locked _inside_ the browser window.
Reporter

Comment 1

5 years ago
Note: this is a different issue than I reported here: https://bugzilla.mozilla.org/show_bug.cgi?id=1085567 which is a problem with PointerLock in e10s mode. This bug occurs in non-e10s mode.

Updated

5 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
Component: DOM: Events → Event Handling
Duplicate of this bug: 1118013
Is this a regression?

(And based on bug 1118013 this is very much valid)
Status: UNCONFIRMED → NEW
Ever confirmed: true
The timing of this bug being filed, and the retina-only of it, does make me wonder if it is more fallout from bug 1092630.
The demo works fine for me on Windows (in a non-e10s window, of course).
First it would be good to know if this works on branches older than 37.  If it does, I'd suspect bug 1092630.
Reporter

Comment 7

4 years ago
Yes the bug is still present in 37.0a1. Works fine on non-retina, goes crazy on retina.

Olli Pettay asked if this was a regression: the bug was introduced shortly before I reported it. I thought it would be picked up in regression tests then, so waited a few days before submitting.
[Tracking Requested - why for this release]: pointer lock (needed for games) broken on OSX retina displays
Reporter

Comment 9

4 years ago
Also, the other bug I reported has been incorrectly marked as a duplicate of this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1118013

I think it's not a duplicate: that bug is an e10s issue (only occurred in e10s mode) and was present before this bug. (Sorry, I don't know the correct procedure to address this: should I post a comment there or here?)
(In reply to Earle Castledine from comment #9)
> Also, the other bug I reported has been incorrectly marked as a duplicate of
> this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1118013

Sorry, I don't understand what you mean.  I'm the one who reported bug 1118013, and I was filing it about non-e10s, which is the same as this issue.  Your e10s one is bug 1085567, and hasn't been duped to anything.

Thanks a lot for filing these issues!  I guess we're missing some test coverage for pointer lock on OSX. :(  (Many e10s tests are not enabled yet, so it not being noticed there isn't too surprising.)
Reporter

Comment 11

4 years ago
**** - sorry! Yes, my mistake (and yes, I confused it for bug 1085567).
(In reply to Earle Castledine from comment #11)
> **** - sorry! Yes, my mistake (and yes, I confused it for bug 1085567).

No problem, thanks for asking for clarification rather than just getting mad about a bug being closed. :)
Summary: PointerLock locks outside browser on retina screen → PointerLock locks outside browser on retina screen in non-e10s mode
This bug, like bug 1117027, is caused/triggered by the patch for bug 1092630:

http://hg.mozilla.org/mozilla-central/rev/a6db8f54f5aa

 Bug 1092630: Get rid of native widgets for OS X NPAPI plugins, make things work much better under e10s. Patch by Josh Aas, Markus Stange, Steven Michaud, David Parks. r=smichaud/jst/josh (more reviews pending)
author	Josh Aas <joshmoz@gmail.com>
	Thu Dec 11 08:44:07 2014 -0600 (at Thu Dec 11 08:44:07 2014 -0600)

Since I've taken bug 1117027, I should probably also take this one, and work on them together.
Assignee: nobody → smichaud
Blocks: 1092630
Status: NEW → ASSIGNED
Thanks Steven!
This has been fixed by the patch for bug 1117027, which has landed on trunk and is present in today's m-c nightly.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
At bug 1117027 I've requested that the patch be uplifted to aurora (the 37 branch).
Fixed on 37 branch by uplifting of patch for bug 1117027 to aurora.
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.