Apps with a 512MB RAM are being listed on devices which have 256MB RAM

RESOLVED DUPLICATE of bug 1112625

Status

P2
normal
RESOLVED DUPLICATE of bug 1112625
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: robhudson)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
Connectivity: wifi
region used: US
Gaia/device: flame/2.0

steps to reproduce:
1. Load marketplace-dev app on your flame device
2. Set your RAM  to 256MB
3. Search for Water? which has 512MB RAM requirement.



expected behavior:
Since Water? has a requirement for at least 512MB of RAM, the app shouldn't be listed.

actual behavior:
Search finds the app.

https://marketplace-dev-cdn.allizom.org/api/v2/fireplace/search/?cache=1&carrier=deutsche_telekom&dev=firefoxos&lang=es&limit=10&pro=7fffffffffff0.51.6&q=water&region=pl&vary=0

ashes: 8704a
Looks like we aren't reindexing properly when feature requirements for an app change, maybe ? According to robhudson the app doesn't have the corresponding feature flag set to true in ES, even though it has it in the db.
(Reporter)

Comment 2

4 years ago
Edited the app's description and robhudson confirmed that the app is now indexed in ES. I still see the app in the search results.

ashes: f84a2

Updated

4 years ago
Assignee: nobody → robhudson.mozbugs
Priority: -- → P2
(Assignee)

Comment 3

4 years ago
The other bug that caused this was fixed. This works for me now. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112625
You need to log in before you can comment on or make changes to this bug.