Closed Bug 1112380 Opened 7 years ago Closed 7 years ago

e10s print.enable_e10s_testing=true + print ==> tab crashed on all tabs

Categories

(Core :: Printing: Output, defect)

37 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1090448

People

(Reporter: u123541, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141216030203

Steps to reproduce:

Needed to print, so set print.enable_e10s_testing=true to try... clicking Print on print dialog appears to work (no errors); but tab crashes.
(opening a new bug instead of re-opening bug 1103399 which didn't seem to have specific trigger)


Actual results:

ALL tabs now showing Tab Crashed.  Must use FF34.0.5/Wine to print... 


Expected results:

Crashing the current tab is understandable; but ALL tabs?
Blocks: e10s
Component: Untriaged → Printing: Output
Product: Firefox → Core
I tried with FF37 (Win7) and e10s enabled, the tab didn't crash when printing to PDF e.g.
Consistently crashes on Linux.  The really bad part is that EVERY tab (350+ over 11 windows) now displays Tab Crashed; EXCEPT:
 - about:* -- have {addons,config,crashes,support} pages open [1]
 - 2 pages with new big spinner
 - 2 random pages which are inexplicably totally blank, even after reloading them

Side-effects:
 - tabs which have been re-sized through Ctrl+wheel show tab crashed message in different sizes
 - Ctrl+0 resets these pages to default size

Print Preview shows the printable page in a new tab; but trying to print it crashes the preview page. Closing the crashed preview page returns to the previewed page which, like ALL others displays tab crashed.

[1] tried printing these about:* pages since they are somehow specially treated ==> bug 1112607
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1090448
Running 37.0a1 (2014-12-22...

Tried printing an IRS order summary page (the one we get when ordering scannable employer forms which cannot be printed locally) and FF crashed as per comment 2; but...

1. Try Again resulted in a totally blank _window_ (no tabs -- nothing)
2. Console had N copies of the following text...  unable to count because N was large enough to scroll through the konsole history which is set at 50,000 lines.

console.error: youtube-all-html5: 
  Message: Error: cannot use a CPOW whose process is gone
  Stack:
    getInnerId@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/pfortin/.mozilla/firefox/iowvrjx2.default-1404854812966/extensions/jid1-qj0w91o64N7Eeg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/window/utils.js:77:3
initialize/model.observe@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/pfortin/.mozilla/firefox/iowvrjx2.default-1404854812966/extensions/jid1-qj0w91o64N7Eeg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/content/worker-parent.js:62:27
Observer<.observe@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/pfortin/.mozilla/firefox/iowvrjx2.default-1404854812966/extensions/jid1-qj0w91o64N7Eeg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/system/events.js:72:7
The blank window would not accept any input/mouse clicks. Close confirmation dialog asked if I wanted to close that window's 32 tabs.  Closed it. Re-opened via History on one of the other remaining windows -- came up on New Tab.  Switched to irs.gov tab and was as if I'd clicked Back several times -- probably due to the fact that this page:
http://www.irs.gov/Businesses/Online-Ordering-for-Information-Returns-and-Employer-Returns
uses cookies to maintain its state.

In case it matters:  my system[1] is setup to group windows into a tabbed window of windows. When I re-opened this blank window, it came up as a separate window indicating that something was different enough to prevent it being grouped into the main window of windows.[2]

[1] Mageia4 (up to date) running KDE4.12.5
# uname -a
Linux prf 3.14.23-tmb-laptop-1.mga4 #1 SMP Sun Nov 2 10:16:13 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

[2] To enable window grouping in KDE:
- right click on Window Menu button
  - More Actions -> Special Window Settings...
    - tab(Arrangement & Access) -> Autogroup with identical + Force + Yes
      (all other settings defaulted)
Restarted FF - now on 37.0a1 (2014-12-29).
During the time I was entering the previous 2 comments, got enough "console error" (comment 4) to scroll completely through another 50,000 lines. FYI, I use colored prompts which makes it easy to scroll through the konsole window looking for the last prompt -- when expecting lots of errors, I hit enter several times to give me about a half-screen of colored prompts which makes it easy to scroll quickly through the 50,000 lines -- so no colored prompts = over 50K lines of output seen... FF was not in a continuous error output state; but I could not say if the messages were in a single, or multiple groups of messages.
You need to log in before you can comment on or make changes to this bug.