ttree is attempting to compile the static docs

RESOLVED FIXED

Status

()

Bugzilla
bugzilla.org
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: justdave, Assigned: justdave)

Tracking

Details

Attachments

(1 attachment)

regression from bug 1108076, ttree is apparently trying to compile the static docs, which are already compiled.

Every docs pass is generating this:

  ! file error - parse error - docs/3.4/en/html/Bugzilla-Guide.html line 15335: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.4/en/html/api/Bugzilla/Template/Plugin/Hook.html line 71: unexpected token (&)
  [% Hook.process("lastrow", "bug/show-multiple.html.tmpl") %]
  ! file error - parse error - docs/3.4/en/html/cust-templates.html line 770: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.0/html/Bugzilla-Guide.html line 15488: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.0/html/cust-templates.html line 768: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.2/en/html/Bugzilla-Guide.html line 15229: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.2/en/html/api/Bugzilla/Template/Plugin/Hook.html line 71: unexpected token (&)
  [% Hook.process("lastrow", "bug/show-multiple.html.tmpl") %]
  ! file error - parse error - docs/3.2/en/html/cust-templates.html line 770: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.16/html/Bugzilla-Guide.html line 10453: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.16/html/cust-templates.html line 686: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.6/en/html/Bugzilla-Guide.html line 15309: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/3.6/en/html/api/Bugzilla/Template/Plugin/Hook.html line 71: unexpected token (&)
  [% Hook.process("lastrow", "bug/show-multiple.html.tmpl") %]
  ! file error - parse error - docs/3.6/en/html/cust-templates.html line 770: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.18/html/Bugzilla-Guide.html line 10151: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.18/html/cust-templates.html line 768: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.22/html/Bugzilla-Guide.html line 13510: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.22/html/cust-templates.html line 770: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.20/html/Bugzilla-Guide.html line 13413: unexpected token (&)
  [% form.<fieldname> %]
  ! file error - parse error - docs/2.20/html/cust-templates.html line 770: unexpected token (&)
  [% form.<fieldname> %]
I'm not having much luck trying to figure this one out.  The copy directive in ttree appears to only work on filenames not on pathnames, and I can't specify the doc directories themselves without a path because the releases tree has the same names in it, and those actually need to be processed.
Created attachment 8537582 [details] [diff] [review]
Patch v1

So the solution seems to be to run ttree twice, the first time configured to completely ignore the docs directory, the second time configured to do only the docs directory and ignore the version-numbered directories.  Then rsync the version number directories over, because I can't seem to convince ttree to copy them.
Assignee: website → justdave
This is running in production already (I had nowhere else to test it).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
for the record:

Checking in bin/build;
/www/bugzilla-org/bin/build,v  <--  build
new revision: 1.6; previous revision: 1.5
done
Checking in bin/build.bat;
/www/bugzilla-org/bin/build.bat,v  <--  build.bat
new revision: 1.3; previous revision: 1.2
done
Checking in bin/build_full;
/www/bugzilla-org/bin/build_full,v  <--  build_full
new revision: 1.7; previous revision: 1.6
done
RCS file: /www/bugzilla-org/etc/ttree-docs.cfg,v
done
Checking in etc/ttree-docs.cfg;
/www/bugzilla-org/etc/ttree-docs.cfg,v  <--  ttree-docs.cfg
initial revision: 1.1
done
Checking in etc/ttree.cfg;
/www/bugzilla-org/etc/ttree.cfg,v  <--  ttree.cfg
new revision: 1.11; previous revision: 1.10
done
You need to log in before you can comment on or make changes to this bug.