mailnews/compose/src/nsMsgCompose.cpp:1476:28: error: 'class nsIScriptContext' has no member named 'GC

RESOLVED FIXED in Thunderbird 37.0

Status

--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

({dogfood, regression})

unspecified
Thunderbird 37.0
dogfood, regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

4 years ago
/builds/slave/tb-try-c-cen-l64-0000000000000/build/mailnews/compose/src/nsMsgCompose.cpp: In member function 'virtual nsresult nsMsgCompose::CloseWindow(bool)':
/builds/slave/tb-try-c-cen-l64-0000000000000/build/mailnews/compose/src/nsMsgCompose.cpp:1476:28: error: 'class nsIScriptContext' has no member named 'GC'
make[5]: *** [nsMsgCompose.o] Error 1
(Assignee)

Comment 2

4 years ago
Created attachment 8537581 [details] [diff] [review]
Fix
Attachment #8537554 - Attachment is obsolete: true

Comment 3

4 years ago
Either this fix or another recent checkin causes the disappearance of the bookmarks in the sidebar and the Bookmarks Manager on my SM-Trunk Linux x86_64.
(Assignee)

Updated

4 years ago
Attachment #8537581 - Flags: review?(Pidgeot18)
Comment on attachment 8537581 [details] [diff] [review]
Fix

Review of attachment 8537581 [details] [diff] [review]:
-----------------------------------------------------------------

Please also remove the nsIScriptGlobalObject.h and nsIScriptContext.h imports at the top of the file.
Attachment #8537581 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 5

4 years ago
Created attachment 8537610 [details] [diff] [review]
Fix v2

> 
> Please also remove the nsIScriptGlobalObject.h and nsIScriptContext.h
> imports at the top of the file.

Done.
Thank you so much!
Assignee: nobody → hiikezoe
Attachment #8537581 - Attachment is obsolete: true
Attachment #8537610 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/comm-central/rev/d655acbc5efe
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
Keywords: dogfood, regression

Comment 13

4 years ago
This change causes nsMsgCompose.cpp to fail with external linkage, presumably because PokeGC is not exported.

Are we sure we really need this at all?

Comment 14

4 years ago
And by "do we need this" I mean maybe we can get rid of the call to PokeGC completely.

Updated

4 years ago
Depends on: 1114686
You need to log in before you can comment on or make changes to this bug.