Closed Bug 11125 Opened 21 years ago Closed 21 years ago

Save as Template fails unless atleast 1 POP & another account

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nbaca, Assigned: rhp)

Details

Build 1999073011M9/Necko: Win32/NT4

Overview Description: Save as Template fails unless the prefs file has atleast 1
POP and another account defined. It doesn't matter what the other account is
(POP, IMAP or News).

Steps to Reproduce:
1. Create a prefs file with 1 POP account only (or 1 IMAP or 2 IMAP accounts)
2. Open Mail
3. Create a new message by selecting the "New Message" button, address it, type
a subject and a short message.
4. In the Compose window select File/Save as Template. The Compose window should
close by itself.
5. Go to the Template folder

Actual Results: Notice the message is not saved to the Template folder.

Expected Results:The message should have been saved to the Template folder.

Additional Builds and Platforms Tested On:
Win32/NT4, using the last non-necko build on 7/28pm, exhibits the same problem.

Additional Scenarios: Created a variety of prefs with the following results -
- 1 pop, fails
- 1 imap, fails
- 2 imap, fail
- 2 pop, works
- 1 pop, 1 imap, works
- 1 pop, 1 news, works

Note: Haven't tried Linux or Mac yet.
Assignee: phil → rhp
reassigning to rhp.  I imagine this is the same problem as the Save As Drafts
bug.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Yes, this was a problem, but checkins today should have fixed it. Basically, I
was going after the wrong folder (most of the time, the Sent folder) every
time.

- rhp
QA Contact: lchiang → nbaca
Status: RESOLVED → VERIFIED
1999080608M9: Win32/NT4
Verified Fixed. Save as Template saved the messages to the Template folder as
expected with or without using the mail.default_fcc_uri pref statement.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.