If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Test failure 'Service is no longer marked for uninstall - 'uninstall' should equal '' ' in /testAddons/testServiceInstallDisableEnableRemove.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mihaelav, Assigned: cosmin)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(firefox35 fixed, firefox36 fixed)

Details

(Whiteboard: [mozmill-test-failure], URL)

Attachments

(2 attachments, 6 obsolete attachments)

(Reporter)

Description

3 years ago
Module:    testDisableEnableRemoveUndo
Test:      testServiceInstallDisableEnableRemove.js
Failure:   Service is no longer marked for uninstall - 'uninstall' should equal ''
Branches:  Beta (35.0)
Platforms: Mac OS X

Reports:
http://mozmill-release.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=Mac&from=2014-12-10&to=2014-12-17&test=%2FtestAddons%2FtestServiceInstallDisableEnableRemove.js&func=testDisableEnableRemoveUndo
The failure message is strange. The reference should be listed as the second part but not the first, and should never be ''.
Daniela, please help us with a skip patch for beta here. Thanks
(Reporter)

Updated

3 years ago
Summary: [zh-CN] Test failure 'Service is no longer marked for uninstall - 'uninstall' should equal '' ' in /testAddons/testServiceInstallDisableEnableRemove.js → Test failure 'Service is no longer marked for uninstall - 'uninstall' should equal '' ' in /testAddons/testServiceInstallDisableEnableRemove.js
Seems only OSX is affected here.
status-firefox35: --- → affected
OS: Linux → Mac OS X

Comment 4

3 years ago
Created attachment 8539132 [details] [diff] [review]
skipServices_V1

I`ve created a skip patch for testServicesInstallDisableEnableRemove.js for MAC
Attachment #8539132 - Flags: review?(mihaela.velimiroviciu)
Attachment #8539132 - Flags: review?(andreea.matei)
Comment on attachment 8539132 [details] [diff] [review]
skipServices_V1

Review of attachment 8539132 [details] [diff] [review]:
-----------------------------------------------------------------

::: firefox/tests/functional/testAddons/manifest.ini
@@ +9,5 @@
>  [testPluginDisableAffectsAboutPlugins.js]
>  [testPluginInDifferentStates.js]
>  skip-if = os == 'win'
>  [testServiceInstallDisableEnableRemove.js]
> +run-if = os == 'mac'

We want to skip on osx.
Attachment #8539132 - Flags: review?(mihaela.velimiroviciu)
Attachment #8539132 - Flags: review?(andreea.matei)
Attachment #8539132 - Flags: review-

Comment 6

3 years ago
Created attachment 8539144 [details] [diff] [review]
SkipServices_V2

Updated patch
Attachment #8539132 - Attachment is obsolete: true
Attachment #8539144 - Flags: review?(mihaela.velimiroviciu)
Attachment #8539144 - Flags: review?(andreea.matei)
Comment on attachment 8539144 [details] [diff] [review]
SkipServices_V2

Review of attachment 8539144 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/ceadc7f1f0ca (beta)
Attachment #8539144 - Flags: review?(mihaela.velimiroviciu)
Attachment #8539144 - Flags: review?(andreea.matei)
Attachment #8539144 - Flags: review+
status-firefox35: affected → disabled
Whiteboard: [mozmill-test-failure][mozmill-test-skipped]
(Reporter)

Comment 8

3 years ago
Created attachment 8539218 [details] [diff] [review]
skip for all OSes
Attachment #8539144 - Attachment is obsolete: true
Attachment #8539218 - Flags: review?(andreea.matei)
Comment on attachment 8539218 [details] [diff] [review]
skip for all OSes

Review of attachment 8539218 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/2783af9a8beb (beta)
Attachment #8539218 - Flags: review?(andreea.matei) → review+
(Assignee)

Comment 10

3 years ago
This can be re-enabled, the fix has been landed in bug 1108948.
Depends on: 1108948
(Assignee)

Updated

3 years ago
Flags: needinfo?(andreea.matei)
(Assignee)

Comment 11

3 years ago
This was re-enabled on beta due to merge, the skip is now only on release branch, and as it didn't failed with latest beta spin, it's clearly fixed.
http://mozmill-release.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2015-01-20&to=2015-01-21&test=%2FtestAddons%2FtestServiceInstallDisableEnableRemove.js&func=testDisableEnableRemoveUndo
We need a re-enable patch, can't backout on release a changeset from beta.
Assignee: nobody → cosmin.malutan
Status: NEW → ASSIGNED
Flags: needinfo?(andreea.matei)
(Assignee)

Comment 13

3 years ago
Created attachment 8552378 [details] [diff] [review]
re_enable.patch

Here is the re-enable patch.
Thanks 

Report:
http://mozmill-crowd.blargon7.com/#/functional/report/dd0cbbf05a3aab4a7676502a86b73e27
Attachment #8552378 - Flags: review?(andreea.matei)
Attachment #8552378 - Flags: review?(andreea.matei) → review+
http://hg.mozilla.org/qa/mozmill-tests/rev/46fee85709d5 (release)
Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox35: disabled → fixed
Resolution: --- → FIXED
(Assignee)

Comment 15

3 years ago
This is still failing, it looks like the dependent bug didn't fixed it. 
One thing I've noticed is that on the dependent bug we didn't had failures on OSX, and on this bug we have only on OSX.

http://mozmill-release.blargon7.com/#/functional/failure?app=Firefox&branch=35&platform=Mac&from=2015-01-22&to=2015-01-23&test=%2FtestAddons%2FtestServiceInstallDisableEnableRemove.js&func=testDisableEnableRemoveUndo
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

3 years ago
Created attachment 8553688 [details] [diff] [review]
skipBeta

Created a new skip patch for the beta branch.
Attachment #8553688 - Flags: review?(mihaela.velimiroviciu)
Attachment #8553688 - Flags: review?(andreea.matei)
Comment on attachment 8553688 [details] [diff] [review]
skipBeta

Review of attachment 8553688 [details] [diff] [review]:
-----------------------------------------------------------------

We're skipping this because the test has several failures on beta. This one, Notification popup state has been opened, aModule.browserWindow is undefined, Share geolocation button has been found.
Attachment #8553688 - Flags: review?(mihaela.velimiroviciu)
Attachment #8553688 - Flags: review?(andreea.matei)
Attachment #8553688 - Flags: review+
https://hg.mozilla.org/qa/mozmill-tests/rev/a3bf1e628a0c (beta)
We want on release too as we ran it today and also is affected.

http://mozmill-release.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2015-01-23&to=2015-01-23&test=%2FtestAddons%2FtestServiceInstallDisableEnableRemove.js&func=testDisableEnableRemoveUndo
status-firefox35: fixed → affected
status-firefox36: --- → disabled

Comment 19

3 years ago
Created attachment 8553690 [details] [diff] [review]
skipRelease

Created a new skip patch for the release branch.

Updated

3 years ago
Attachment #8553690 - Flags: review?(mihaela.velimiroviciu)
Attachment #8553690 - Flags: review?(andreea.matei)
Comment on attachment 8553690 [details] [diff] [review]
skipRelease

Review of attachment 8553690 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/qa/mozmill-tests/rev/9e4cf8a3b117 (release)
Attachment #8553690 - Flags: review?(mihaela.velimiroviciu)
Attachment #8553690 - Flags: review?(andreea.matei)
Attachment #8553690 - Flags: review+
(Assignee)

Comment 21

3 years ago
I tried to reproduce this today, I ran the affected test in loop for about 40 times and 10 complete testruns but I couldn't reproduce it.
You tried on an affected machine or locally?
(Assignee)

Comment 23

3 years ago
Yes, I tried the same on a production node, I had the same output, it didn't failed.
(Assignee)

Comment 24

3 years ago
Since the issue was fixed in the dependent bug, I investigated the difference in the test version that failed and the default one that it didn't. So what we had was also a bug that failed to cancel the uninstall, but which didn't got backported to beta.
This is bug 1094784.
(Assignee)

Comment 25

3 years ago
For release we need the fix from bug 1088551, so I guess we could let the train handle it.
(Assignee)

Comment 26

3 years ago
Created attachment 8561910 [details] [diff] [review]
re-enable patch beta

The fix has been transplanted to beta and release, so the test can be re-enabled.
Attachment #8539218 - Attachment is obsolete: true
Attachment #8552378 - Attachment is obsolete: true
Attachment #8553688 - Attachment is obsolete: true
Attachment #8553690 - Attachment is obsolete: true
Attachment #8561910 - Flags: review?(andreea.matei)
Comment on attachment 8561910 [details] [diff] [review]
re-enable patch beta

Review of attachment 8561910 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/qa/mozmill-tests/rev/824df1633656 (beta)

On release it doesn't apply.
Attachment #8561910 - Flags: review?(andreea.matei) → review+
status-firefox35: affected → disabled
status-firefox36: disabled → fixed
(Assignee)

Comment 28

3 years ago
Created attachment 8562557 [details] [diff] [review]
re-enable patch release

Here is the patch for release
Attachment #8562557 - Flags: review?(andreea.matei)
Comment on attachment 8562557 [details] [diff] [review]
re-enable patch release

Review of attachment 8562557 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/qa/mozmill-tests/rev/af0997254c51 (release)
Attachment #8562557 - Flags: review?(andreea.matei) → review+
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-firefox35: disabled → fixed
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure]
You need to log in before you can comment on or make changes to this bug.