[Statusbar] Icons overlay rocketbar after searching

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: apastor, Assigned: apastor)

Tracking

unspecified
x86
macOS

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
STR:

1.- Enable as many icons as possible (NFC, Wifi, etc)
2.- Make sure there are more icons when the statusbar is maximized than when is minimized
3.- Go to Settings
4.- Click on 'Search the web'
5.- Click on 'Close'

Expected:

The statusbar icons go back to the previous state

Actual:

The statusbar icons overlay the rocketbar input
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Comment 1

4 years ago
After bug 1074332 landing, the result is not seeing the statusbar icons at all, instead of the overlapping.
(Assignee)

Updated

4 years ago
Attachment #8538462 - Flags: review?(etienne)
Comment on attachment 8538462 [details] [review]
[PullReq] albertopq:1112520-icons-rocketbar to mozilla-b2g:master

r=me with a small unit test in the 'handle events' section
Attachment #8538462 - Flags: review?(etienne) → review+
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
There was an error creating the taskgraph, please try again. If the issue persists please contact someone in #taskcluster.
(Assignee)

Comment 5

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/9a99b5deba9ba20bde3a0ff5402908ba84d87c92
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Sorry about the taskgraph failure above - turns out this is caused by treeherder being down in bug 1113356.
This issue is verified fixed on Flame 2.2.

Result: The status bar icon does not overlap with the rocket bar.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.