[Flame][Homescreen]The figure on shortcut of bookmark is serrated.

RESOLVED INVALID

Status

Firefox OS
Gaia::Homescreen
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8537736 [details]
1.png

[1.Description]:
[Flame][v2.1&2.2][Homescreen]Add bookmark to home screen,the figure on the shortcut is serrated.
see figure 1.png.
[2.Testing Steps]: 
1.Launch e.me.
2.Input social.
3.Tap Twitter or Facebook.
4.Tap Menu and add to home.
5.Back to home.


[3.Expected Result]: 
5.The shortcut figure should be displayed clearly.

[4.Actual Result]: 
5.You can see the figure on the shortcut is serrated.

[5.Reproduction build]: 
Flame 2.1 version:
Gaia-Rev        79286eafe67707d1330966c1b1413b2d0de595d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/222a62b532db
Build-ID        20141216001202
Version         34.0
Flame 2.2 version:
Gaia-Rev        af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a3030140d5df
Build-ID        20141216040205
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,3/3
Free Test
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
(Reporter)

Comment 1

4 years ago
Hi Eric,could you help to check this issue?
Flags: needinfo?(echang)
An issue but we probably have no control over that. but ni RD for confirmation. 
Hi Christian, could you comment on this, thanks..
Flags: needinfo?(echang)

Comment 3

3 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #2)
> An issue but we probably have no control over that. but ni RD for
> confirmation. 
> Hi Christian, could you comment on this, thanks..

Hi Eric ,this issue still exist on flame 2.1&2.2,need NI Christian or not?
Flame 2.1
Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
FLame 2.2:
Build ID               20150227002521
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c8a38dcfbebc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flags: needinfo?(echang)
FWD ni to RD for comment.
Flags: needinfo?(echang) → needinfo?(crdlc)
Basically icons for bookmarks are provided by system app, it means that if the icon is a favicon as FB for instance and it does not have a great resolution this is rendered as the attached image by UX design. You can have a web page with <link rel="icon" href="icons/favicon.png"> where favicon.png should be 128x128 for example and you should see this properly.

https://github.com/mozilla-b2g/gaia/blob/master/shared/elements/gaia_grid/js/grid_icon_renderer.js#L101

Maybe Kevin could have more info about this
Flags: needinfo?(crdlc) → needinfo?(kgrandon)
Yup, as Cristian says this is an evangelism issue. If you download the app from the marketplace, we should serve high quality icons. The other option is to work with Facebook/Twitter to provide the necessary <link> tags in their markup. Closing this out as there's nothing we can do here and this is by design.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.