Status

()

--
major
RESOLVED DUPLICATE of bug 105225
17 years ago
17 years ago

People

(Reporter: fred, Assigned: hyatt)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Linux BuildId 20011112012 (Mozilla 0.9.6)

Sometime, Mozilla stays on top of other windows when a new window is raising
itself (like Gabber when I receive a new instant message). This is a random
behaviour. When mozilla is in such state, even minimizing it has no effect =>
mozilla maximizes itself immediatly.

This problem has appear with Mozilla 0.9.5 and was not present in Mozilla 0.9.4

Window Manager is SawFish 1.0, with GTK+ 1.2.10
Reporter:
0.9.5 is old, can you please try it again with 0.9.6 ?

Comment 2

17 years ago
Reporter, do you minimize browser windows before they start loading anything
from the web? If yes, it is a duplicate of bug 92170. See that bug for details.

Updated

17 years ago
Target Milestone: --- → Future

Comment 3

17 years ago
I'm also experiencing this problem with: Sawfish 1.0, Gtk+ 1.2.10

From what I am seing this may be common to sawfish users.
Its an extreemely random bug that only affects me about once or twice a day when
trying to minimize or switch active windows. Somehow mozilla seems to always
grapple its way to the top window.

Pressing the back button seems to stop this from happening. Maybe its something
on certain pages that triggers this?

Im currently on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
and experiencing this exact problem.
(Reporter)

Comment 4

17 years ago
The problem I described appeared in Moz 0.9.5 and is still present in 0.9.6

The minimize part of this bug seems to be a duplicate of 92170.

But there is still a problem with Mozilla staying on top..

Comment 5

17 years ago
> But there is still a problem with Mozilla staying on top.
Leaving minimizing aside, there were two bugs (bug 77675 and bug 97067) on focus
stealing. There were fixed before 0.9.5 release. One still remains (Linux
specific?): bug 105225. Is this related to your problem?
(Reporter)

Comment 6

17 years ago
Yes, I think so.. Duplicating..

*** This bug has been marked as a duplicate of 105225 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.