[Flame][Music]The progress bar indicator and "-" overlap

RESOLVED DUPLICATE of bug 910454

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 910454
4 years ago
3 years ago

People

(Reporter: Paladin, Unassigned, Mentored)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8537753 [details]
logcat_flame_1442.txt

[1.Description]:
[Flame][v2.1&2.2][Music]The progress bar indicator and "-" overlap while we are playing an audio with more than 24 hours duration after the remaining time show -01:02:**.
Attachment: logcat_flame_1442.txt and Overlap.png
Occurrence time: 14:42

[2.Testing Steps]: 
Set up: Have an audio with more than 24 hours duration.(The full duration of the audio: 24:02:17)

1. Open Music
2. Play an andio with more than 24 hours duration.
3. Until the remaining time show -01:02:**

[3.Expected Result]: 
The progress bar indicator and "-" should not overlap.

[4.Actual Result]: 
3. The progress bar indicator and "-" overlap.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        79286eafe67707d1330966c1b1413b2d0de595d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/222a62b532db
Build-ID        20141216001202
Version         34.0

Flame 2.2 build:
Gaia-Rev        af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a3030140d5df
Build-ID        20141216040205
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8537754 [details]
Overlap.png

Comment 2

3 years ago
This issue still exist on flame 2.1 &2.2
2.2 build:
Build ID               20150226002503
Gaia Revision          bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gaia Date              2015-02-26 01:52:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/363123044e61
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
2.1 build:
Build ID               20150226001720
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Flags: needinfo?(echang)

Comment 3

3 years ago
Created attachment 8570875 [details]
2015-02-27-11-58-51.png
Rare case, seldom have a music that long, but nice to have this fixed, suggest to backlog this. 
Ni RD for comment.
QA Whiteboard: [COM=Gaia::Music]
Flags: needinfo?(echang) → needinfo?(dkuo)

Comment 5

3 years ago
This should be a easy bug(patch with css only) and I think it can be a good practice if someone wants to contribute music app, setting the mentor to myself and feel free to ni me again if it becomes a blocker, thanks.
Mentor: dkuo
Flags: needinfo?(dkuo)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910454
You need to log in before you can comment on or make changes to this bug.