Some characters are displayed as unicode codepints in offline messages

RESOLVED FIXED in Future

Status

RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: ji, Assigned: tao)

Tracking

({l12y})

Trunk
Future
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This is moved from bugscape. (http://bugscape/show_bug.cgi?id=10794)

With a Ja build, after going offline, when selecting a message which is not
downloaded, the message view page will display an explanation saying that the
message is not downloaded and you need to go back to online.... In this message,
some characters are displayed as raw unicode codepoints. 

Steps to reproduce:
1. Launch Mail.
2. Select File | Offline, a dialog will pop up asking if you want to download
the message, answer no.
3. Select a message in the mail box, the explanation will be displayed in
message view pane.
(Reporter)

Comment 1

17 years ago
Nominating for nsbeta1, this looks very bad on Ja builds.
Keywords: l12y, nsbeta1
(Reporter)

Comment 2

17 years ago
Created attachment 58743 [details]
A screenshot on Ja build.
(Reporter)

Comment 3

17 years ago
Copied Ray's comments on bugscape bug:
------ Additional Comments From rchen@netscape.com 2001-11-13 14:53 -------

The problem is the string contains several "\n\" at the end of the lines to
continue the message. The parser can't take care of "\\uxxxx", which causes the
problem.  I wonder the second "\" is necessary for properties file. 

Comment 4

17 years ago
I think this is a localization issue. "\\uxxxx" is treated as '\' and "uxxxx"
whcih is a correct behavior.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
Can you give us the advice to localize the string without the problem?

nocachedbodybody =The body of this message has not been downloaded from \n\
the server for reading offline. To read this message, \n\
you must reconnect to the network, choose Offline from \n\
the File menu and then select Work Online.\n\
In the future, you can select which messages or folders to read offline. To do 
\n\
this, choose Offline from the file menu and then select Synchronize. You can \n\
adjust the Disk Space preference to prevent the downloading of large messages.

Comment 6

17 years ago
Tao, do you have suggestion? Can that be \n instead of \n\?

Comment 7

17 years ago
Apparently \n is not working. The work around I can think of is to remove all 
\n\ to make it a single huge line and it works. But it sucks.

Comment 8

17 years ago
Parser should do a better job. It should not connect the second \ character to 
the first character in the next line. Naoki, Do you know who owns the parser? We 
should talk to them regarding this issue. 

Reopen the bug. 
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 9

17 years ago
I think Harish owns parser, cc to him. But this has to be resolved at string
bundle level before getting to the parser.

Comment 10

17 years ago
Do you know who owns the string bundle handling?

Comment 11

17 years ago
Reassign to tao.
Assignee: nhotta → tao
Status: REOPENED → NEW

Comment 12

17 years ago
nsbeta1-
 L10N can workaround by combining into a single line
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Comment 13

17 years ago
per #12
Target Milestone: --- → Future

Comment 14

17 years ago
This bug should be closed now, since we had a fix in bug 144345.
FIXED per comment.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.