"Social Fixer" add-on does not work with e10s

RESOLVED INCOMPLETE

Status

()

Firefox
Extension Compatibility
RESOLVED INCOMPLETE
3 years ago
3 months ago

People

(Reporter: earthsound, Unassigned)

Tracking

({addon-compat})

unspecified
x86
Windows 7
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
gecko build ID: 20141217030202
changeset: b7eb1ce0237d
build identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

-- setup --
enable e10s
install Social Fixer (http://socialfixer.com/download.html)
load https://facebook.com

-- expected result --
Social Fixer loads

-- result -- 
Two JavaScript error windows pop up:
injectScript: TypeError: window.QueryInterface is not a function
contentLoad: TypeError: window.QueryInterface is not a function

And Social Fixer doesn't load. 

Opening this as a blocker for tracking bug 905436.
hi Matt, your Social Fixer add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org or ask Ally on this bug. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
tracking-e10s: --- → +
With Firefox 57 only WebExtensions are permitted and are, by default, e10s compatible.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.